Ford Power Stroke Nation banner

1 - 7 of 7 Posts

·
Registered
Joined
·
68 Posts
Discussion Starter #1
Hey everyone has anyone had any experience with the powermaster starter for a 7.3? My truck has been lazy starting as of late I know a lot of people have mentioned the DP starters but I've read a bunch of mixed results on them. Any feedback would be much appreciated. Have a happy New Year and be safe
 

·
Administrator
Joined
·
8,053 Posts
i only use starters from the rebuild shop up the highway. they depend on their name to stay in business. if they put out garbage they go out of business.
internet companies don't have that problem and can put out garbage as i found out years ago with bd and other supposed "good" units.
plus, the local guys are usually cheaper too.
 

·
Project Shamu
Joined
·
2,467 Posts
WHS ^, unfortunately I dont have any local rebuild shops (that I could find atleast).

I ended up just getting a OE starter from AutoZone, get an 03 model as they are factory GR. They crank PLENTY fast enough.
 

·
Registered
Joined
·
5,494 Posts
I have read that the Powermaster starter is a good replacement. I have also read that DB's replacement parts are now junk.

For another good starter look at the Denso

Sent from my SM-J737V using Tapatalk
 

·
Registered
Joined
·
55 Posts
I know kinda late but my starter went out last month and always want the real nippo sensor starter but was always seen for 400+ with shipping.

Then I did some research and called sensor auto parts and asked for a list of authorized dealers and Napa auto came up. But did not see it on there website or in store. But with little more research I found out that Napa auto rebox's the denso starter in thier box's under different part number.

As seen in picture below. Just wanted to let people know. I also signed up for their notification and recieved a percentage off of online order and got starter even cheaper. Paid less then 250 out the door.


Sent from my SM-N920P using Tapatalk
 

·
Registered
Joined
·
55 Posts
Less then $270 Sorry for typo

Sent from my SM-N920P using Tapatalk
 
1 - 7 of 7 Posts
Top