Ford Power Stroke Nation banner

1 - 6 of 6 Posts

·
Registered
Joined
·
83 Posts
Discussion Starter #1
About 7 weeks ago I was making a u turn and hit a pothole. My high pressure line blew out of the pump. I replaced it and now I'm having a bad leak where the line plugs into the pump. I've taken it off and put it back multiple times. With and without Teflon. Am I not supposed to tighten this fitting all the way? The washer where it goes in the pump is where I think my problem is. I think I read that over tightening can booger the washer and cause leaks.


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
1,189 Posts
sounds like the nut in ur PS pump is messed up( where the High pressure hose connects to). I think it has a flair fitting on the hose, SO Teflon wont do anything
 

·
Registered
Joined
·
83 Posts
Discussion Starter #3
My truck has a build date of 11/97 so it has a o-ring fitting rather than a flare. I bought a new I/ring and it still shoots out. I may try a new hose and the piece the female that screws into the pump.


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
3,563 Posts
No you're not supposed to overtighten that fitting. The line should be able to move with it tight.
 

·
Registered
Joined
·
83 Posts
Discussion Starter #5
That part is still loose. The leak is from the threads where the hose screws into the p/s pump outlet.


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
83 Posts
Discussion Starter #6
I talked to the guy at the auto parts store and he thinks I missing an O-ring. How many should there be ? Is there one on the end that goes in the gear box?


Sent from AutoGuide.com Free App
 
1 - 6 of 6 Posts
Top