Ford Power Stroke Nation banner
1 - 14 of 14 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter · #1 ·
So my dad has a 2004 Ford F-350 6.0L that only has 80 thousand miles on it. Its a very very nice truck. About 3 months ago he lost an injector so he had the whole one side done with injectors due to financial problems. Anyways now when we are driving around and the truck shifts into overdrive. If you push the pedal decently hard in overdrive it was make the whole truck vibrate really bad. But then when it shifts down then it has no problem. What do you guys think this could be?? Tranny related?? Maybe a sensor. I'm not very familiar to 6.0's being I have a 1996 7.3l. Any help would be very appreciated!!
 

·
Big dumb *******
Joined
·
4,200 Posts
Codes...need to scan it for codes. If an injector is misfiring, it'll cause this exact same issue to happen. Not saying that's the case, but without getting it scanned, it's just a guessing game.
 

·
Banned
Joined
·
142 Posts
tcc shudder???
On the fords I have had some good luck with a product from Dr Tranny called shudder fix.
It is easy to use. And will not have any bad side effects.
 

·
Former Ford Trans Engr.
Joined
·
3,220 Posts
Don't put shudder fix in this trans! It will have bad effects on the solenoids, and it won't fix your problem. This trans DOES NOT have a problem with converter shudder. Your shudder problem is one or more injectors, it is not in the transmission.
 

·
Registered
Joined
·
41 Posts
Discussion Starter · #9 ·
Its supposed to be done today but we havent gotten a call so not a clue yet. They say that the 5th injector was bad. It was bad before so we replaced it. Which is weird because this injector failed in less then 6 months.
 

·
Former Ford Trans Engr.
Joined
·
3,220 Posts
You would think so, but that isn't the case. It only becomes apparent with enough load on the engine. You are only getting enough load when it is in overdrive.
 

·
Big dumb *******
Joined
·
4,200 Posts
My dads does the same thing. Only does it once it shifts to OD and locks the TQ. His #8 injector needs replacing, that I know. I'm with Mark here. I'd be willing to bet you have an injector issue.
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top