Ford Power Stroke Nation banner

1 - 20 of 21 Posts

·
Lookin for Operating Job
Joined
·
234 Posts
Discussion Starter #1
Ok I have had nothin but problems with this truck and now I have another one I believe to be injectors but I pray it aint. I just got my FICM rebuilt and programmed with the 03-04 original programming. I got it back yesterday and hooked it up (bought new batteries also) and noticed that the middle plug case on the wiring harness side was cracked. So I pushed it back together and plugged it in. Hooked everything else up. It cranked right up but it wasnt runnin off all the cylinders. I tried to mash the throttle and it took a short period of time for it to rev up. It still didnt seem to be runnin on all cylinders. I let it run for a couple min but never seemed to run normal. I shut it off then tried to start it back up and it wouldnt even crank over. Please tell me what the hell the problem is. I am an E5 in the navy with a baby due April 5th(this coming monday). I can not afford this crap right now. PLEASE HELP YALL!!!
 

·
Registered
Joined
·
3,600 Posts
Why did you get it programmed with the original flash?
 

·
Lookin for Operating Job
Joined
·
234 Posts
Discussion Starter #5
The 05 programming aint the same as the 03-04. So programming it back to those years original then I gain faster response time and 3-5mpg
 

·
Lookin for Operating Job
Joined
·
234 Posts
Discussion Starter #6
Do you think that REV-X stuff would help or is it worth a shot and if so where can I get it??
 

·
Registered
Joined
·
3,600 Posts
Sounds like you could have an issue with that FICM...
 

·
Lookin for Operating Job
Joined
·
234 Posts
Discussion Starter #8
Well I need to test to make sure there is power comin from it. I hope thats what it is. Is there really anyway to check FOR SURE????
 

·
Registered
Joined
·
3,600 Posts
Can you swap another FICM in to see if it fixes the issue? I would be looking there first considering right after you changed it you are having injector issues...
 

·
Lookin for Operating Job
Joined
·
234 Posts
Discussion Starter #10
thats kinda what I was thinkin or maybe cause of that plug. Can I just take one out of another truck or what??
 

·
Registered
Joined
·
3,600 Posts
I think you can just take one from another truck, but I am not 100% sure on that.
 

·
Lookin for Operating Job
Joined
·
234 Posts
Discussion Starter #12
Well I don't really know where I can get another one from. I just ran the DTC's and there is none so I really dont know.
 

·
Lookin for Operating Job
Joined
·
234 Posts
Discussion Starter #14
Ok I really think that it has to do with that plug. Just from really thinkin about it. Now I really don't want to replace the whole harness. I would really like to just replace that plug. IS THIS POSSIBLE?? Does anyone know someone that has one available. I cant seem to find one. I really need to get this done. Tired of only having one truck between the wife and I. Plus she is due this monday. So REALLY need one. Thoughts and help please. Thanks
 

·
Stroken it 7.3,6.0,6.4
Joined
·
1,239 Posts
Trying to think but I don't think a whole engine wire harness is that expensive?I just did one last week and think it was around 200-300 at the most if I remember right. Check out this guy for a price www.partsguyed.com
 

·
2Cruel
Joined
·
1,645 Posts
someone sells the replacement plug ends, not sure who though i have seen it,

I have seen Swamp build these things and he tests them very good before they leave, i am sure that thing is working just fine!!

try wiggling the plugs around and see what happens

Travis
 

·
Lookin for Operating Job
Joined
·
234 Posts
Discussion Starter #18
1 - 20 of 21 Posts
Top