Ford Power Stroke Nation banner

1 - 12 of 12 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
so my truck has been down for about a month now, when it first started acting up the injectors were chattering really bad and it was loping aggressively and when I took it down the road it would have good acceleration and then it would fall off and the pedal would almost be dead, so I limped it home, let it cool down and shut it off. waited about 10 minutes came back out and it wouldn't start. I called my mechanic from work the next day and it fired right up for him and he trailered it to his shop. when he scanned it, it had thrown the cps code 47 times and also had codes for injection pressure and high pressure oil pressure. so $865.64 later with a cps, and ipr, it runs fine for him and when I pick it up I cant make it out of the driveway without it dying (note it was a moist wet day). he scanned it again and it had thrown the cps code again. after that day he couldn't get it to act up again. he replaced a injector harness that was ugly and it still threw the codes. he put in a spare idm ran a whole tank of fuel through it and never through another code or acted up, I went to pick it up last night in the snow and It started doing the same thing.... I will note, the spare idm was not his and he had taken it out after he narrowed it down to that, I had him put it back in so I could take it home and put in a new one on my own, but when he put it back in he didn't bolt it back down. I don't know if I should order a new idm or look for other explanations any advice is greatly appreciated. thanks in advance I am stumped on this one.
 

·
Registered
Joined
·
3,408 Posts
Looks to me like 1) You should change mechanics. 2) You need to replace your IDM with a replacement, get known working one from an auto wreckers, plug it in and I've it a whirl.

jrc
 

·
Registered
Joined
·
31 Posts
Discussion Starter #3
truck still is not fixed, I found that the guy before me cut the main power cable to the ignition and wrapped it around another wire for the gauges and taped it.. I could poke it and the truck would shut right off, soldered the wire back to normal and wired my gauges to a switch. now I thought that would solve the problem, drove it two days and the problem came back. the truck will idle fine but if I put it in gear and give it throttle it dies.also if I have it out of gear and hold the rpms around 1600 it will kind of stutter or cut out I just put a reman idm in it thinking that the voltage drops could have fried it and nothing changed, now im not sure what to try.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #4
also after the truck dies it is hard starting when I try to fire it back up, but it usually starts on the third try, and I cant just turn the key on and off three times I have to let it cycle or it wont fire,but this is only a problem after it dies otherwise it fires right up.
 

·
Registered
Joined
·
79 Posts
A friend of mine said he had a '97 that would idle all day long but would die when he tried to drive it. I don't know if it died right away or threw codes but he said the problem was the engine harness.
 

·
Squeezing out Torque...
Joined
·
157 Posts
So with the scanner he had, he couldn't read live data? Such as HPOP (ICP) pressure, ICP cyle and IPR cycle? Because those would relate to the codes that were thrown and would be the first things I'd look at. Next would be physical fuel pressure, which are more related to the symptoms rather than those codes.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #8
yes, he did read the live data and did a cylinder contribution test, he replaced the ipr and said everything checked out..do you think the wire shorting could have messed up the cps? and with the engine harness you are talking about the one going to the valve cover correct?
 

·
Registered
Joined
·
15 Posts
Ask the mechanic where he-she purchased the CPS. If at the local auto supply house and not Ford or International then that's part of the problem. Aftermarket CPS replacements don't work properly .. seen it dozens of times in the past. It's one of the parts you want to be OEM.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #10
Have new oem cps on the way thanks for the advice, i will update when i get it in
 

·
Registered
Joined
·
6 Posts
yes, one of those "advance auto" CPS's have screwed me before. i have an OEM one in now and no problems!

i had my IDM go bad since water was in it. but when my alternator was wore out i could honk my horn at any RPM and it would kill the engine. after i installed a new alternator and IDM it was fixed.

but when my truck would die, it would take about 3 times to get it started too.
there is a dealer on Ebay that you can send your old IDM to and they will send you a rebuilt one with a lifetime warranty as long as you send your old one back!

just some things that i have gone through! the electrical components on these engines can be killers! good luck!
 

·
Registered
Joined
·
31 Posts
Discussion Starter #12
Ya i had one of the lifetime warranty ones but that didn't fix my truck so i returned it and they were easy to work with. I put the new cps on and i haven't had a problem yet so hopefully it stays that way but now i think i need a new speed sensor. Thanks for all of the input, Has anyone ran one of the "updated" international cps?
 
1 - 12 of 12 Posts
Top