Ford Power Stroke Nation banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Got a problem here and looking for some advice... Hooked a computer up to my Ford F-350 7.3 and not reading any codes! This truck wont start once left for more than 4 hours in cooler tempatures unless block heater is pluged in! Batteries are good, gpr is working gp are all working injectures are fine! Could the pcm be the cause of the no start problem?

Thanks in advace
 

·
Horsepower Enthusiast
Joined
·
370 Posts
Yes it could be but it's not likely, when the PCM goes it stays gone most the time. LOL

Sounds more like you have a ground issue. Check the two grounds on driver fender to make sure they are clean and tight.

Also (this may sound dumb but I've dealt with it more than once) make sure your battery terminals are clean and tight! I've seen intermittent loss of PCM communication caused by that before.
 

·
Registered
Joined
·
295 Posts
Not to hijack your thread but i have the same issue but i can pull codes from mine one was p0605 PCM ROM Error
 

·
Old Yeller, REBORN
Joined
·
2,284 Posts
Also (this may sound dumb but I've dealt with it more than once) make sure your battery terminals are clean and tight! I've seen intermittent loss of PCM communication caused by that before.
Good point, worth checking into.
 

·
Registered
Joined
·
295 Posts
where are the gounds that you check on the fender?
 

·
Paul
Joined
·
160 Posts
How many miles on your truck?
Did you ohm out the glow plugs at the valve cover connector?
Did you measure voltage drop across the GPR?
 
1 - 6 of 6 Posts
Top