Ford Power Stroke Nation banner

1 - 13 of 13 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Driving home and my '15 f350 6.7 flashes Reduced Engine Power, dies and will not start back. At first it was giving p2291 code. I noticed fuel wad under 1/4 tank, added fuel. Tried starting again, nothing. I have changed the fuel pressure/temp sensor, fuel filters, fuel lines from low pressure pump to rail,and low pressure filter housing. Need ideas!!!!
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
Yes low pressure pump runs. Had mechanic check pressure while cranking. He said 400psi. I have changed filters twice and check for water and metal both times. It's clean.
 

·
Registered
Joined
·
4,946 Posts
You said you changed it? Did you remove the VCV on the pump to check it? It’s possible I suppose. It’s also common for the wiring pigtail to fray right at the FRP sensor. You can also remove the fuel regulator at the back of the drivers side fuel rail to check for debris and or rust
 

·
Registered
Joined
·
7 Posts
Discussion Starter #7
The sensor I changed is the one one the fuel line. It is directly in front of the upper filter.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
Also yesterday it popped a crankshaft position sensor code. I am guessing that is most likely from the extended cranking?
 

·
Registered
Joined
·
4,946 Posts
PRObably due to excessive cranking. If you have sufficient fuel pressure I would say chase that code but with 400 psi it will never run.

The high side pressure sensor is on the front of the drivers side fuel rail. The fuel pressure regulator is on the back of that same rail. The VCV is on the top of the HPFP.
 
1 - 13 of 13 Posts
Top