Ford Power Stroke Nation banner

1 - 16 of 16 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1 (Edited)
1997 F-350 nearly stock except for a down pipe and no cat.
So I have this intermittent issue . If I’m traveling down the road at highway speeds and let off the throttle then get back into the throttle I loose throttle response . The Check engine light comes on, if I hold the pedal down I will coast for about twenty seconds or so and suddenly it will
Come back to life and run fine . Also if and when this happen I engage the clutch and let the engine idle I’ll gain my throttle back and go like normal . This will also occurs while I have it on cruse control, it will shut my cruise down.
I’ve replaced ipr, icp, and throttle sensor. I did live datata on a scanner and on my high pressure oil pump I was seeing nearly 5000 psi at times . Any idea what could be going on would be awesome . Not running any type of chip or anything .
 

·
Registered
Joined
·
10 Posts
I'm having the same issue with my 95 7.3. I've been chasing down this problem for months now. While in neutral try bring your rpms up to 3000 and see if theres any certain rpms where it will bog down.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
Ok I’ll give it a try but I actually took it to the dealership today bc I have also had this issue for months and can not figure it out . Maybe they can tell me something . Did you have any issues when you tried that ?
 

·
Registered
Joined
·
10 Posts
I found out that between 2000 and 2500 rpms it would start to sputter then it would pick up and take off like at normal wide open throttle, put a guage on the hpop and noticed a slight hesitation in pressure when it hit 2000. Did you notice oil in or around the valley at all?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
I found out that between 2000 and 2500 rpms it would start to sputter then it would pick up and take off like at normal wide open throttle, put a guage on the hpop and noticed a slight hesitation in pressure when it hit 2000. Did you notice oil in or around the valley at all?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
Oh ok, I don’t have any issues when reveling it up. It doesn’t sputter or anything runs fine actually . Mine will only do it intermittently and usually it’s at high rpms but I’m driving . I’ve rev’d it several time last but don’t notice any change . No oil valley either .
 

·
Registered
Joined
·
10 Posts
Oh ok, so your data from scanning the hpop should be good. What did you do when you scanned the hpop, take it on the highway at all?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #10
Just got my truck from the dealership . They are saying I have no contribution on cylinder three and cylinder two . They also claim my icp has oil in it saying it needs replaced . Basically all the dealership did was plugg into it and didn’t drive it in an attempt to get it to do what I told them . Never even drove it on the highway .
 

·
Registered
Joined
·
10 Posts
Go figure, they probably didnt know what to do when they see it was an obs. Have you checked for any oil in the fuel bowl? I dont see how an injector can through a p1211 if it's not o-rings.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #12
I don’t have any oil in the fuel bowl, actually changed out the filter thinking g maybe it was some fuel related issue. So you got the same kind of deal going on ?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #14
Damn, hey random question you may be able to answer . I was trying to do the max ac mod but having some issues . Any idea what the actuator under the hood is just above the blower motor on the passenger side is . Also does you’d have vacuum when you put it on max ac ?
 

·
Registered
Joined
·
10 Posts
That should be what changes your air to different locations like defrost, vents. And no my ac has been wacky for some time, I've just been working on everything else.
 
1 - 16 of 16 Posts
Top