Ford Power Stroke Nation banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
A few weeks ago I was having issues with white smoke coming from my exhaust in the mornings when it was cooler. I contacted the dealer and they said that it was probably the EGR valve and to bring it in. I took my truck in and they found several other issues as well but all were covered under warranty. I know they changed out the high pressure oil pump and the intercooler I believe. Well a few days after I got it back I was driving and my oil pressure went to zero and would only come up if I gave it a little throttle. I immedietly parked it and called them the next morning. They sent a tow truck to get it and looked at it the next day. They called me and told me that they could not find an issue and that it was probably the cluster and it would cost about 800.00 to replace. I went and got it later and they said the truck finally did what I said and they thought it was the sending unit and that I could safely drive the truck until I fixed it. Well the oil pressure came up today and was working fine then I started smelling burning oil. I pulled over and noticed oil leaking from under the truck and it appears to be coming from the top of the motor. I am confused why the when the oil pressure started woring again with no issues I get a leak. Has anyone seen or heard of this issue?

it is a 2006 F250 6.0 that just turned over 100,000 yesterday
 

·
Registered
Joined
·
878 Posts
Mine's an 06 and I have had some crazy oil press readings on my Autometer's also....Yesterday at 80degree's it was around 20psi and today it was back to 80 so who know's...I always get a quick puff at start up and have had no other issue's as far as I can tell she's running top noch.....that being said it will fluctuate when throttled...jus figure'd it was time for some new oil.....who knows....I will be watching this thread though hope ya get her str8!

Oh yeah no blowing or leaking oil.......
 

·
I Just Break Stuff
Joined
·
2,201 Posts
Top of the motor front or back?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
its hard to tell exactly where its coming from but it looks close to the sending unit
 
1 - 4 of 4 Posts
Top