Ford Power Stroke Nation banner

1 - 8 of 8 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
Ok, I've been working on why my 7.3 has been at a loss for power. Some guys suggested switching out the K & N filter I've been running in the stock air box, I'll try that now that I switched out my majorly leaking power steering reservoir. While changing out the power steering pumps, you have to take out the air box tube to the turbo and the intercooler tube from the turbo to the intercooler. The tube from the air intake to the turbo had a light film of oil evenly on the internal walls, the aluminum tube from the turbo to the intercooler had enough oil in it, probably a tablespoon of dirty oil dripped out of the lower part of the intercooler tube, IS This normal or could it be a source of my power loss?
 

·
Village Idiot
Joined
·
8,209 Posts
Your powerloss is prob leaky up pipes.
 

·
Registered
Joined
·
633 Posts
Plus boost leaks from old oily boots.
 

·
Village Idiot
Joined
·
8,209 Posts
Those are easier to hear..,i had a loose clamp and it sounded like the horn of vahalla ate a burrito.
All i had was a loose clamp..
that said when i did my glow plugs i washed out the pipes, and boots that connectrd to those...
 

·
Registered
Joined
·
31 Posts
Discussion Starter #7
thanks gentlemen, when the weather breaks and I switch to the 6637 Napa filter instead of my K & N, I'll wash out my pipes and put on new boots.
 

·
Registered
Joined
·
243 Posts
When you get new boots, just upgrade to Riff Raff's kit. New boots that are oil resistant.
 
1 - 8 of 8 Posts
Top