Ford Power Stroke Nation banner

1 - 20 of 59 Posts

·
Registered
Joined
·
1,189 Posts
Discussion Starter #1
After the new injectors

 

·
Registered
Joined
·
3,033 Posts

·
Registered
Joined
·
1,189 Posts
Discussion Starter #3
I'm not 100% sure if the map sensor is the problem. I've got a 3/8" plug in my tee assembly for my boost gauge and I took
The plug out "so the boost could escape and fool the map sensor " but it still ran about the same.
 

·
Registered
Joined
·
1,078 Posts
I don't think an OBS PCM defuels like a Super Duty does.

I can get my boost to 25-30 PSI with stock injectors without any problems.
 

·
Registered
Joined
·
1,189 Posts
Discussion Starter #5
Some say they de fuel some say it doesn't .on stock injectors my truck to make 20-25 pounds boost and it never de fueled. Now with the hybrids I'll hammer it an she shoots up to 30 then backs off to about 15psi
 

·
Registered
Joined
·
1,078 Posts
Have you got custom tunes for the injectors?
 

·
Registered
Joined
·
1,189 Posts
Discussion Starter #8
Yes php tunes and stock hpop. 230,xxx . That was my next idea on what might b wrong .
 

·
Registered
Joined
·
1,078 Posts
I would bet your problem isn't the PCM defueling, it is the HPOP isn't getting enough oil to the injectors for them to run.
 

·
Registered
Joined
·
1,189 Posts
Discussion Starter #10
Could be it . I've had the chip in for about 2 weeks . It had no problem hitting 40 psi the first few days. Now it won't hardly go past 15 . My plan was to get a srp1 , but I just got a email from rosewood diesel saying it could be months before the are back out. What else is good?
 

·
Registered
Joined
·
1,078 Posts
I have read good things about the Adrenaline pumps. That is what I have been looking at getting.

7.3L Adrenaline HPOP
 

·
Registered
Joined
·
5,346 Posts
sometimes the OBS sensors get pissed off when the boost rises too fast..... just put a popoff on it or a regulator for 18 psi or so.
 

·
Registered
Joined
·
1,189 Posts
Discussion Starter #14
Here's another video . When the boost drops the truck barley wants to accelerate . I'm gonna try and get it on a scanner tommorw to see the hpop psi under wot


 

·
Registered
Joined
·
1,078 Posts
I still think it is a HPOP problem. I think your PCM isn't seeing the correct HPOP PSI and is shutting it down to save the engine.
 

·
Registered
Joined
·
1,189 Posts
Discussion Starter #16
That's what I'm leaning towards also. Hybrids on a old hpop aren't the best combination .
 

·
Registered
Joined
·
1,078 Posts
A stock 15* HPOP will not run stage 1 injectors very well.
 

·
OBS junkie
Joined
·
8,250 Posts
A stock 15* HPOP will not run stage 1 injectors very well.
A good 15 will still run better then a weak 17. FWIW my little 180k+ mile 15 with a new IPR last year runs my 275/200s just fine. Never thrown a CEL & pulls hard, haven't had a chance to data log it but I will one of these days. Could I use bigger oil? Oh F yeah, just rather spend my money on more important upgrades right now like the tranny/turbo & what have ya.
 

·
Registered
Joined
·
1,078 Posts
A good 15 will still run better then a weak 17. FWIW my little 180k+ mile 15 with a new IPR last year runs my 275/200s just fine. Never thrown a CEL & pulls hard, haven't had a chance to data log it but I will one of these days. Could I use bigger oil? Oh F yeah, just rather spend my money on more important upgrades right now like the tranny/turbo & what have ya.
I'm not going to argue that it ran them "fine" with the proper tuning. However, to get max potential out of those injectors you need more oil. The stock 15* HPOP barely gets the most out of the stock injectors.
 

·
Registered
Joined
·
1,189 Posts
Discussion Starter #20
Ok just got it off the scanner . On my hot tune at wot oil pressure was at 2500 psi
 
1 - 20 of 59 Posts
Top