Ford Power Stroke Nation banner

1 - 4 of 4 Posts

·
Registered
Joined
·
294 Posts
Discussion Starter #1
All,

After getting my truck back from the dealer (and $2K later...) on the way home, vacuum pump locked up, shredded the belt, slightly/lightly overheated about 2 miles from home and limped it into the driveway.

One thing that was recommended since everything else is rebuilt and I am tracking down the road speed vibration is that I should replace the engine and trans mounts. So I have them coming (along with Vacuum pump, PS pump, belt, etc...) and was wondering how bad are they to change?

Truck is not rusty, and is 2WD but I will be on my back in the driveway. Just seeing if anyone here has changed their and what are the watch outs. Any feedback is appreciated.

Cory
 

·
Registered
Joined
·
1,322 Posts
It's been several years since I did one, but here's what I remember, don't take all three out at once if you can help it, it will make it easier to locate going back together. The motor mounts on these are basically two loops with a rubber insulator, make sure the engine is not slid backwards or forwards causing metal to metal contact. That can cause all kinds of weird unsavory noises and what not.

And if you are like me, your gonna smash a finger at some point. Somewhere, somehow, sometime.

Side note: is that a K series in your avatar?

Sent from my E6810 using Tapatalk
 

·
Registered
Joined
·
294 Posts
Discussion Starter #3
Yes, QSK50. I have broken, cut, gouge, poked enough over my years of wrenching that is a given. Electrical tape is my Band Aide of choice.

I would never pull them all at once, more curious about the clearance to fasteners noth at the block and at the “K” member.

Cory
 

·
Registered
Joined
·
1,322 Posts
Ok, been to long ago to remember exactly what I used. Good luck. And nice avatar! I wish I could afford one of those.

Sent from my E6810 using Tapatalk
 
1 - 4 of 4 Posts
Top