Ford Power Stroke Nation banner

1 - 15 of 15 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a problem with the transmission, first through second and third it raises the rpm and hits the shifters and the tow / haul light comes on. and stays at 5 and does not enter 6, codes p0756,p2701, I have been replacement the solenoid B, pressure plug, internal wire harness, valve body screen gasket, fluid filter, reprogram the pcm and still doing the same
 

·
Former Ford Trans Engr.
Joined
·
3,077 Posts
P0756 can only set from a solenoid that isn't working. In this case, solenoid B. You've changed that, which should have taken care of the problem. All of the other things that you changed couldn't possibly have fixed this.

All I can guess is that either you didn't clear the code and it's still in memory, or the new solenoid is also no good.
 

·
Registered
Joined
·
7 Posts
when accelerating the first gears shift very erratic, high rpm and then the tow / haul light start blinking, stop accelerate hard and the gears shift perfect at time but the last gear never shift
 

·
Former Ford Trans Engr.
Joined
·
3,077 Posts
Solenoid B is used to make the 1-2 shift and the shift to overdrive. So your symptoms confirm that the code is right and Solenoid B is not working properly.
 

·
Registered
Joined
·
7 Posts
Mark I will change again the solenoid B and see what happens, one question: the TCM could be bad? The person who reprogram the PCM told me it’s no way to know if it’s good or bad PCM, only if I buy new one
 

·
Registered
Joined
·
4,947 Posts
If you’re already done all you say in the first part, including checking the wiring to and from the PCM, the problem is likely mechanical, most likely a clutch piston problem. IME the PCM will set a solenoid performance code, and a clutch apply time code (same as your case) with a mechanical problem with said clutch (in your case, overdrive ).
 
1 - 15 of 15 Posts
Top