Ford Power Stroke Nation banner

1 - 20 of 20 Posts

·
Registered
Joined
·
545 Posts
Discussion Starter #1
What is normal hpop bleed down? After I turn my truck off the icp dropsby around 10psi every second when watching with ae

I'm trying to track down the cause of a hard cold starting problem with my truck
 

·
FORD..THE ROCK CRUSHER
Joined
·
2,346 Posts
once the pump stops turning there is no more PSI..it probably goes out the drain back valve...you could check the oil level in the reservoir first thing in the morning before you crank if you think its oil related...cold hard starts are most commonly a GP issue..
 

·
Registered
Joined
·
545 Posts
Discussion Starter #3
I have a Cali truck with a glow plug controller which outputs codes for bad glow plugs, no codes, plus I did resistance checks which turned out fine, so I don't think it's a glow plug issue
 

·
Registered
Joined
·
545 Posts
Discussion Starter #4
The icp sensor gets it's reading from the drivers side head, if the pressure is dropping when the motor is off then the oil must either be leaking or draining somehow, how does the oil circulate?
 

·
OEM Moderator
Joined
·
9,381 Posts
Hangdog had some posts showing the rate at which his system slowly bled off pressure that you might be interested in.
 

·
Registered
Joined
·
545 Posts
Discussion Starter #6
thanks for the heads up


Here is the link
injector pressure test ?s - Powerstroke Nation

looks like he held 2000psi down to just over 1000psi for 10 mins

I assume that was in the pressure rail in the heads?

I did some reading in the obs 7.3 forum and some guys mentioned having low hpop resi's overnight and having leaky injector o-rings.

Is it possible for an injector oring to leak hp oil into a cylinder?
 

·
OEM Moderator
Joined
·
9,381 Posts
thanks for the heads up


Here is the link
injector pressure test ?s - Powerstroke Nation

looks like he held 2000psi down to just over 1000psi for 10 mins

I assume that was in the pressure rail in the heads That was when he was pressure testing his heads trying to diagnosis a weak ICP issue with a aftermarket HPOP?
I did some reading in the obs 7.3 forum and some guys mentioned having low hpop resi's overnight and having leaky injector o-rings.

Is it possible for an injector oring to leak hp oil into a cylinder? NO
...
 

·
Registered
Joined
·
5,909 Posts
What is normal hpop bleed down? After I turn my truck off the icp dropsby around 10psi every second when watching with ae

I'm trying to track down the cause of a hard cold starting problem with my truck
Totally normal. The system is designed to bleed the pressure off. After all, we don't want the rails holding oil pressure indefinitely, do we?:doh:

Probably glowplug related. To verify, use the block heater one day and see if the truck fires normally.
 

·
Registered
Joined
·
545 Posts
Discussion Starter #9
Totally normal. The system is designed to bleed the pressure off. After all, we don't want the rails holding oil pressure indefinitely, do we?:doh:

Probably glowplug related. To verify, use the block heater one day and see if the truck fires normally.
Thanks for the info


What about the hpop tank bleeding down? i'm going to check that today to see how low the oil level is before I start the truck, what should be the norm?

Anyone have any suggestions around the glow plugs? they all meter out at 1.2ohms! which is the higher end of the spec but all the same... I don't have a GPR, just a glow plug module (cali truck) if that was bad I would think it would throw a code?
 

·
FORD..THE ROCK CRUSHER
Joined
·
2,346 Posts
oil level should be at least 3/4 inch from the top..cant help with the GP..i dont know much about the cali trucks....sorry
 

·
Registered
Joined
·
545 Posts
Discussion Starter #11
If the oil level is lower then 3/4" below the top what would be the cause other than external leaks?
 

·
Registered
Joined
·
545 Posts
Discussion Starter #12
Oil level was down about 1 1/2" from the top outside of the tank
 

·
Registered
Joined
·
5,909 Posts
1 1/2" is low, but not low enough to cause an issue. It would need to be nearly empty.

Cali trucks usually do throw codes, if the GP module is bad, but stranger things have happened. Did you try the block heater experiment? Sure sounds glowplug related.....:doh:
 

·
Registered
Joined
·
545 Posts
Discussion Starter #14
I re-checked the glow plugs yesterday
all 1.5ohms for the passenger side, all 1.2ohms for the drivers side...

is 1.5 too high?

I'll try the block heater in the next few days

thanks for your help
 

·
Registered
Joined
·
545 Posts
Discussion Starter #15
Ok I tried the block heater and it started up very well.

So I guess it must be my glow plugs

Earlier in the week after I plugged in the truck, I removed my TW chip the to get re-burnt for hybrid injectors that are on the way.

Without the chip I have codes for ALL the glow plugs comming up!!!

That has me thinking that the base tune in the truck wasn't calibrated for a cali truck with glow plug control module? is this a possibility
 

·
Registered
Joined
·
5,909 Posts
I think you found the problem! Congrats!

If it's that glow plug module, get ready for sticker shock. That thing isn't cheap. :doh:

But first, clear the codes. See if they come back with no chip. Also, call TW and remind him you have a Cali truck.
 

·
Registered
Joined
·
545 Posts
Discussion Starter #17
Thanks for the advice, I already cleared the codes but they came right back up, kinda weird that it's all 8 glow plugs and they still meter out ok... According to some ford troubleshooting info 0.1-2ohms is within spec!
 

·
Registered
Joined
·
4,865 Posts
Its the module and you are looking at $140+ for one. Would sure be nice to have those relays back. Most all the Excursions have them as I found out when I first did my fuel filter change. I had keep a extra relay for my 99 but do not think I will be doing so for the X at the cost of these things.
 

·
Registered
Joined
·
545 Posts
Discussion Starter #20
isn't there a specific code for the module?
 
1 - 20 of 20 Posts
Top