Ford Power Stroke Nation banner

1 - 12 of 12 Posts

·
09 6.4
Joined
·
989 Posts
Discussion Starter #1
i was driving down the road and the truck kind of jerked and i had no foot feed. i coasted into a driveway and pulled two codes... p2885, p0237. i also have swapped the accelerator assemble with another trucks and still has the problem. any ideas whats goin on?
 

·
Registered
Joined
·
67 Posts
Will the truck start and idle? If so it's most likely ICP sensor...you can unplug it and see if the truck acts any better, I drove mine for several days with the thing unplugged before the CEL started getting on my nerves. If you have a hard time keeping the truck running it might be the FICM, but my money is on the ICP.
 

·
09 6.4
Joined
·
989 Posts
Discussion Starter #3
the truck will start and idle just like normal. i tried unplugging the icp while it was running and there it still will not accelerate...so check the FICM?
 

·
09 6.4
Joined
·
989 Posts
Discussion Starter #4
i have now swapped the icp sensor, the pcm, and the accelerator peddle off of another truck and still having the issue. the truck will idle but it doesn't sound as if the turbo is whistling, but every once in awhile the turbo will whistle for a few seconds and then go back to nothing...
 

·
Registered
Joined
·
1,543 Posts
Wow awesome, I had the same problem it was a fuse, I'd never figured that out

Chad
 

·
09 6.4
Joined
·
989 Posts
Discussion Starter #9
actually i am having the problem again...i swapped over the FICM from another truck yesterday and it started and acted fine. so i put it all back together and then my dad had to take the truck somewhere and he didn't make it a mile from the house before he had to coast into a driveway. we had to pull it back home so now im thinkin that its gotta be a wiring problem somewhere. do you know what fuse number that it was that was blown?
 

·
Registered
Joined
·
1,543 Posts
I don't remember. I can ask my wife ( she had the problem while I was deployed as well ). She also remembers those stupid little trivial things lol, half the time I don't remember wiping my own ass lol

Chad
 

·
09 6.4
Joined
·
989 Posts
Discussion Starter #12
errrr right haha! colby ur a retard! and its just a wiring prob. somewhere cuz we got it to working fine now and hopefully it wont act up
 
1 - 12 of 12 Posts
Top