Ford Power Stroke Nation banner

1 - 20 of 21 Posts

·
Powerstroke Tunnel Vision
Joined
·
43 Posts
Discussion Starter #1
I completed a search on the forum and have had no luck finding a thread to help so I am open for ideas.

Went to smog my truck in CA today a 2001 F250 stock with exhaust and a little over 218K on the odometer. Everything checked out with flying colors except for the check engine light does not cycle when you turn to start while waiting for the glow plugs to cycle. To be completely honest my wife and I have had the truck for almost 8 years and I don't think I have ever seen the Service Engine Soon light ever on this truck.

I did remove the cluster and try swapping bulbs around for the hope of a simple fix but nothing changed.

I am open to any ideas as I need to smog it in the near future.

Thank you all in advance!
 

·
Registered
Joined
·
3,784 Posts
You have to watch very very very closely. When you turn the key to run, it will flash for a millisecond. Probably wouldn't even be able to detect it on a multimeter, unless you have a really good one.


Sent from my SM-N960U using Tapatalk
 

·
Powerstroke Tunnel Vision
Joined
·
43 Posts
Discussion Starter #3
I did check very closely but still not light. And to add insult to injury I failed the smog as the tech said there was no light.

I have now checked all of my fuses and no luck there unfortunately.
 

·
Registered
Joined
·
5,889 Posts
Do you get any other lights when you first turn the key on, that is besides the WTS light?

Have you looked at the dash on a dark night with all the cab lights out when you first turn the key on?

I'm not sure just what runs the CEL at the initial key on but it is just a self check. Have you set a code deliberately and then looked to see if it comes on?
 

·
Powerstroke Tunnel Vision
Joined
·
43 Posts
Discussion Starter #5
Great questions. I have all the other lights on the dash with the key on as I do in my other truck. I just checked in the dark and I still dont even have a flash on of the SES.

I have not tried to set a check engine light yet. Is there something I can unplug and try?
 

·
Registered
Joined
·
5,889 Posts
Unplugging just about any sensor should set a CEL.

I'd try the ICP or the MAP sensors. But do you have a way of clearing the code when it is set?
 

·
Powerstroke Tunnel Vision
Joined
·
43 Posts
Discussion Starter #7
Got it. I took tomorrow off to try and work on this some more. I do have a diesel code reader so I won't have any issues clearing the codes. I will keep you posted on what I find out. Thank you for the help.
 

·
Registered
Joined
·
3,784 Posts
Not that I think that is the issue here, but I have seen people cut the wire to the light before.....

Sent from my SM-N960U using Tapatalk
 

·
Registered
Joined
·
5,889 Posts
That is where he would need a pin out of the PCM connector to verify if the PCM is sending out the ground to light the light.
 

·
Powerstroke Tunnel Vision
Joined
·
43 Posts
Discussion Starter #10
So after unplugging the ICP and the MAP sensors no check engine light. Not sure where to go from here. Is there a diagram that would show me how to pin test the PCM?
 

·
Registered
Joined
·
3,784 Posts
It's pin #2.
You can Google a pin-out.
I dont know if it sends power or ground to the light.

Sent from my SM-N960U using Tapatalk
 

·
Registered
Joined
·
5,889 Posts
I'm pretty sure that it is a switched ground or a 0.5 reference voltage such as what the PCM sends to the glow plug relay to activate it.

Most vehicles will switch grounds. That way they only need to provide a fused power to a central spot and don't have to worry about fusing everything in sight

For the OP, this may be something that you would want to talk to a dealer about.
 

·
Powerstroke Tunnel Vision
Joined
·
43 Posts
Discussion Starter #13
Pin number 2 got it. I ran out of time yesterday to get back to it but I am going to try and tackle this weekend. I am going to look up which one that is and test it! Thank you for the help.
 

·
Powerstroke Tunnel Vision
Joined
·
43 Posts
Discussion Starter #14
Sorry I never thought a 2 year old and a newborn would consume so much of my time! I am hoping to get back on this Thursday or Friday. I will keep you all posted and thank you again for your help up to this point.
 

·
Powerstroke Tunnel Vision
Joined
·
43 Posts
Discussion Starter #15
Well I was supposed to work on my truck today but my wife got the flu. Hopefully I can get to it next weekend. Thank you again for the help so far.
 

·
Powerstroke Tunnel Vision
Joined
·
43 Posts
Discussion Starter #16
So after some testing last weekend I found 12 volts going to the wait to start light and nothing going to the SES light. I decided to splice in the WTS and SES to see if I could get the light to turn on. Nothing. Any ideas less a instrument cluster replacement?
 

·
Registered
Joined
·
3,784 Posts
Check the bulb?

Sent from my SM-N960U using Tapatalk
 

·
Registered
Joined
·
5,889 Posts
Most electronic switching is down with grounds and not the voltage.
 

·
Powerstroke Tunnel Vision
Joined
·
43 Posts
Discussion Starter #19
Yep switched bulbs all around with known good ones. Got it. I will examine the grounds this weekend and see what I can find.
 

·
Registered
Joined
·
5,889 Posts
You need a EVTM for your truck, without it you are just shooting in the dark. A pin out of the PCM connector will help a whole lot in telling you what wire goes to the CEL in the dash. Right now you are thinking that it is in the dash when it could be the PCM or in the wiring going to the light.

Also a code reader will help you letting you know if the CEL light has been set.
 
1 - 20 of 21 Posts
Top