Ford Power Stroke Nation banner

61 - 64 of 64 Posts

·
Registered
Joined
·
79 Posts
Discussion Starter #61
Well I stand corrected :). Hows the truck coming otherwise?
Just got the injector delivered this morning and installed it after work. Still running like crap. Guess I'll be getting a whole set of injectors when I get my tax return.
 

·
Registered
Joined
·
79 Posts
Discussion Starter #62
Well I stand corrected :). Hows the truck coming otherwise?
I mean it's gotta be injectors right? Good (albeit minimal) compression across the board of 350psi. Good steady fuel pressure. Clean fuel. Electrical all checks out fine. I'm thinking the fuel side of the injectors were extremely contaminated, just strange the way it started and the fact that it's not just one injector. Valve train all looks just fine. I had started it the other day and it seemed to run great for about 30 seconds after it ran crappy for 30 seconds, but went back to running crappy. Icp and ipr look fine. Low duty cycle and good pressure when commanded. Went ahead and replaced the CPS when I did the #2 injector today too. So frustrating.
 

·
Registered
Joined
·
79 Posts
Discussion Starter #63
I've been avoiding spending the money to have the injectors tested ($280 here locally)... 1 stock remanufactured injector already cost me $150 for no improvement. I feel like my best bet now is to just get a whole set. And if I do that I'm gonna get some 205/30 hybrids and a new hydra tuner at $2200 🤑🤮 I really don't want to add $280 for testing on top of that. Then again I wanted to put that $2200 towards wheels and tires. 🤣
 

·
Registered
Joined
·
79 Posts
Discussion Starter #64
So I went ahead and ran another cylinder contribution test and it passed this time... I had expected it to throw #2 again since it is a fresh rebuilt injector and the others are old but nope. 2.2K ohms puts EOT at 215⁰F by the way. Anyways, I'm kinda stumped. Not sure how to proceed.
 
61 - 64 of 64 Posts
Top