Ford Power Stroke Nation banner

21 - 29 of 29 Posts

·
Administrator
Joined
·
8,349 Posts
kinda sorta, yes and no.
the 5 star takes away the dead spot in the throttle so when ya step on it it is instant throttle instead of wait 2 seconds then go.
it also changes timing and trans shift points for better mileage in economy tune, or more power in performance tune.
when you call mike before ordering the tuner, tell him what you want, and he will write the tune to your specs.
 

·
Registered
Joined
·
624 Posts
Discussion Starter #22
Avr 14.0 mpg to Fort Worth with 2 hours of idle in construction zone, then 13.25 mpg on the way back to Houston in the rain sometimes in a driving rain slowing us to 40 mph on the highway but when I could do it we did 85 mph most of the way.

Twas my second road trip in that truck....it was nice and comfortable.

I need a radar detector.
 

·
Registered
Joined
·
624 Posts
Discussion Starter #24
I put a new windshield in this vehicle, OEM quality made in the USA. $395.

I bought a Thinkware F800 dash cam and an Escort Radar detector...this truck just drives fast.

It uses the same oil filter as my wife's '08 Mustang WIP.
 

·
Registered
Joined
·
624 Posts
Discussion Starter #25
Just did a 10 day vacation on Hilton Head island...2,269 round trip miles, burned 170 gallons of gas at avr 2.39 gallon $407 total fuel cost. Avr MPG was 13.3 on the return trip it took 15 hours to go 1048 miles. Stopped 3 times for fuel/leg stretch.

The radar detector paid for itself on the way to HHI SC.

And yep, we was there for Hurricane Florence. Told us to evacuate on Tuesday...we left this past Saturday...beaches were empty and so were the restaurants!
 

·
Registered
Joined
·
624 Posts
Discussion Starter #26
This past weekend I was towing a Silver Streak travel trailer, we were 100 miles into a 408 mile trip and I proceeded to hammer the throttle to pass a big rig....got past the rig then no power, it was idling but no throttle response there was a wrench being displayed on the monitor. I pulled over shut it off and then restarted, still the same...I have an Edge CTS2 and ran codes...nada....ran the clear codes. Shut it off, restart...all is well. We drove the remaining 300 miles
and then drove back the next day no issues. Did I over rev and the 6.2 didn't like that? Any Ideas what happened?
 

·
Registered
Joined
·
624 Posts
Discussion Starter #27
I got a P0308 code the other day while driving....after a few minutes the code went away and the engine resume normal operation...is this code for miss fire on #8? would that be caused by a weak coil? I have just over 75k on this truck.
 

·
Administrator
Joined
·
8,349 Posts
could be coil, but my bet is a weak spark plug or wire.
at 75k, the plugs are about at life expectancy.

i know the book says 100k, but 75 is more like it.
at 93k, my truck only had 3 of the 16 plugs firing 100 percent. 3 were totally dead.
 

·
Registered
Joined
·
624 Posts
Discussion Starter #29
ok I will pickup the parts and see about changing those plugs out....and get some new wires. Maybe I can do my wife's WIP at the same time....she is over 115k miles and I am guessing they are originals also. Thx Tom.
 
21 - 29 of 29 Posts
Top