Ford Power Stroke Nation banner

1 - 11 of 11 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
So we changed the fuel filter thats in the frame rail yesterday, hoping that would fix the water in fuel problem. I got in my truck to head to work, and drove a good 15min. Then I get on the gas to pass a car up and the RPMs shot up and the MPH went no where. My speed started dropping and id try to give it gas and all that would move is the RPM. I pulled into a field and came to a stop and the truck sputtered and sounded rough before turning off. I tried restarting it and all it would do is crank, but not turn over. I had the truck towed home thinking it could be the fuel pump. My dad checked the fuel pump today and its working. So what could be the problem now? I want to try all possibilities before towing it to Ford.
 

·
I Just Break Stuff
Joined
·
2,201 Posts
Sounds like your tranny went home to Jesus. That doesn't explain the no start. Need a little more info. Need to scan it.
 

·
Registered
Joined
·
652 Posts
So we changed the fuel filter thats in the frame rail yesterday, hoping that would fix the water in fuel problem. I got in my truck to head to work, and drove a good 15min. Then I get on the gas to pass a car up and the RPMs shot up and the MPH went no where. My speed started dropping and id try to give it gas and all that would move is the RPM. I pulled into a field and came to a stop and the truck sputtered and sounded rough before turning off. I tried restarting it and all it would do is crank, but not turn over. I had the truck towed home thinking it could be the fuel pump. My dad checked the fuel pump today and its working. So what could be the problem now? I want to try all possibilities before towing it to Ford.
If you had your sig filled in that would help---
What year
What mods if any
How many miles on it
Do you have gauges what kind of boost if you have a boost gauge did it over boost? you say rpm shot up what did the trans do when they went up.
Did you change the fuel filter up top use Ford Filters or Racor filter?
2 stroker
 

·
Registered
Joined
·
207 Posts
the no start could be ur cam position sensor or crank position sensor but i think ur rpm tack reads off of ur crank position sensor. it could also be ur hpop if u arent building the pressure it wont fire the injectors. i would start with the cam sensor. as for the transmission check to see how much fluid is in it.
 

·
Registered
Joined
·
255 Posts
umm yeah what was wrong with the filter because that wont make it fall out of gear going down the highway
 
1 - 11 of 11 Posts
Top