Ford Power Stroke Nation banner

1 - 16 of 16 Posts

·
Registered
Joined
·
5,464 Posts
Discussion Starter #1
Im adding an intercooler from my 99, injectors from the 99 (AB's), gauges and of course a Tony Wildman chip to top it all off. Cant wait to get it done, its been pretty stock up until now (gutted ebpv, down pipe, cat delete, open air) and has pulled great so far. The new mods should really wake it up, hope teh ford reman trans holds lol. :ford:
 

·
Registered
Joined
·
5,464 Posts
Discussion Starter #3
confused about what? Im putting the left overs from the 99 onto my 97 ;). No need for a 17 pump, it will only have a mild tow burn to help keep the trans alive.
 

·
Registered
Joined
·
5,464 Posts
Discussion Starter #5
nah had the 97 for over a year, just did start modding it much until now.
 

·
Registered
Joined
·
5,464 Posts
Discussion Starter #7
yes house is sending me one to use until i find a good deal on one.
 

·
OEM Moderator
Joined
·
9,381 Posts
I would not be surprised if a 17deg pump made a noticable difference in how it runs even with AB injectors


Tom
 

·
Non Helpful Member
Joined
·
818 Posts
yeah when my 97 had stock ab's with the 15degree pump with a 75hp chip i could get it down to 1500psi Joey had AE one day on the high setting pulling a trailer I was around 1325psi:rolleyes:
 

·
Registered
Joined
·
5,464 Posts
Discussion Starter #12
wow, thats bad. The truck has a fresh pump and ipr o rings so hopefully it will be fine. Heck im sure our 80 yr old driver will be tickled it pulls even better and im sure he could care less about icp LOL.
 

·
Registered
Joined
·
5,464 Posts
Discussion Starter #13
well got to test the new mods out today and it worked flawlessly. Now as to why i had to test the new mods out.... I had another freaking stock hpo line pop. Apparently when my mechanic swapped out the hpop gaskets he failed to make sure there was adequate clearance between the hpo line and the glow plug relay bracket. There was a nice little spot wore through the braided wire, oil everywhere including on the hot turbo. I'm surprised my truck isn't burnt to the ground and i think synthetic oil might be the only reason it didn't burn. Best part of all, no CEL (p1211) when i went wot up a nice long hill :)
 

·
Taters #2 Fan
Joined
·
825 Posts
damn luke you have the worst luck. Glad the obs is runnin like a champs. OBS's RULE THE WORLD!!!
 

·
Registered
Joined
·
18 Posts
You right there Rusty! My OBS still kicking but now pulling the 35 ft 5th wheel and the 20 ft boat on Jon's freshened up E4OD. Total weight now with everything full and me standing on scale is 24,000. Will run 85 MPH on GPS but it is topping 1400 pre turbo! Jon and I are swaping out some machine work on tranny parts (I think yours) and some of his Mustang work for an Intercooler set up.
 

·
Taters #2 Fan
Joined
·
825 Posts
Yeah. If you got parts from jon right now they are mine. I'm sitting and waiting. as soon as they are done I'm off to indiana.
 
1 - 16 of 16 Posts
Top