Ford Power Stroke Nation banner

1 - 3 of 3 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
I have been lurking for a few weeks, and I figured it was time to sign up.

I have a 1999 F350 Crew Cab, short bed, SRW that I picked up.

Truck won't start unless plugged in. Has a miss until she's idled for probably 20 mins or so. The truck sat for 2 years until I bought it and drove it home last week. The owner plugged the truck in for a few hours, I put two batteries in and drove it home.

The seal on the oil filter is leaking, the dipstick adapter was leaking (repaired while lurking) and now I have a top end oil leak, so I went ahead and pulled the trigger on hpop o rings and pedestal seals along with an air filter and oil filter.

I figure it's best to leave the old oil in until I get it to stop leaking, that way I don't watch money pour onto the ground.

IPC tests out and so does the GPR. I am wondering if the hpop lines leaking could cause a starting issue if they are bleeding off too much pressure to the rail.

Also, the jack-leg mechanic put the trans lines on incorrectly, stacked all of the crush washers to the outside of the banjo fitting instead of sandwiching it, so those need replacing.

The exhaust stops at the down pipe as well. Probably going with a diamond eyez 4" back. Seems to be the most economical route.

Once the truck is up to temp she runs fine.

I'm sure I'll be posting in other sections.
 

·
Trust me, I got this...
Joined
·
1,377 Posts
Welcome! If the high pressure oil lines or hpop was leaking, you would have oil pouring out very quickly. Look at replacing the glow plugs and the relay; that is probably the no start issue.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #3
Welcome! If the high pressure oil lines or hpop was leaking, you would have oil pouring out very quickly. Look at replacing the glow plugs and the relay; that is probably the no start issue.
It's leaking pretty bad. Fair bit of oil in the valley. After a drive, oil is coming down the back (bell housing) I've put maybe 50 miles on it, level was full; added about 5 quarts to set back level yesterday.

I figured I'd get a set of MC ZD11's and valve cover gaskets next week, and check the injectors while I was at it. Test the glow plugs and whatever is good, pull and keep for spares but replace the set anyways for piece of mind.

The I jumped the GPR yesterday and no change in starting. Gonna put a meter on it this evening. I'll be going to a White Rogers (Stancor) if it needs replacing.
 
1 - 3 of 3 Posts
Top