Ford Power Stroke Nation banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
08 f-350 c&c 6.4 replaced the engine with a long block with tins. Rebuilt injectors and pump also new lpfp. Deleted egr and dpf with xrt pro. Finally got all air bled out of system and got it fired off. Cranks then starts but runs at around 450 rpms for around a second then picks up to 650 rpms and idles smooth. Has zero power no smoke and no codes. Rail pressure running in specs according to auto enginuity program. Any ideas would help

Here is a little back story on the truck from what I have figured out. When I got it the previous owner had parked it in a field for 3 years said he was not sure what was wrong with it but mice had made a home in the engine compartment. Cleaned all the mice crap out and fixed wires and such, changed all fluids, new batteries and she fired right off. Dropped dpf and put programmer on it On mild tow haul mode and it ran like a scalded dog with broke exhaust bolt. Ran 6 months like this no problems then injectors and pump went south but knew I was on borrowed time anyway. Pulled cab started disassemble and kept going till found 3 cracked pistons. Searched till found a built long block that I could afford that a guy was going to put in his truck but had a change of plans. All was rebuilt on the engine and studded but he said the injectors and pump had 80k miles on them, no problem because I had injectors and pump at home already. All assembled and now I have no power issues. Engine came from a 08 international 2ton that flywheel broke on and driver let idle for 3hrs waiting on tow truck and destroyed bottom end.


I am about ready to find a stick or case of dynamite for it.
 
1 - 1 of 1 Posts
Top