Ford Power Stroke Nation banner

1 - 7 of 7 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #1
Hey there, I finally got around to installing my new clutch after the HPOP oil soaked my last one. But now I have a notciable vibration when the truck is running . Its not in the driveline because it vibrates in neutral when stopped at certian RPMs:1200-1500 and above 2500. Is this common or do I have a major problem and need to take it out again:doh:. Kind of a pita. Thanks for any help.
 

·
Registered
Joined
·
4,865 Posts
Sounds like a clutch/flywheel balance issue to me. By rev'n in neutral with the clutch depressed in full so its fully disengaged and thus isolating the trans from it if you are getting vibration it would have to be in the clutch flywheel. If it does not vibrate like that but does when you are in neutral but the clutch pedal is not depressed then I would think this would indicate a possible issue with the trans. That is just off the top of my head. I have not had to mess with manuals in a number of years but that was always a basic test for isolating clutch flywheel issues from trans drive line issues.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #3
Just went out and tried it with the pedal pushed in or out and the vibration is present either way.
 

·
Registered
Joined
·
4,865 Posts
Its a clutch flywheel balance issue. You are gonna have to pull it and have it rebalanced but double check all of this with someone that does this stuff a lot. If you think it thru I think you will see this makes sense but still I do not want to be responsible for you spending the better part of day ripping crap out if its not needed. Good news is its not anything behind it i.e.the tranny or drive shaft etc
 

·
Death Row Inmate #7
Joined
·
1,458 Posts
what brand clutch is this? what all did you replace? clutch, pressure plate, throwout bearing, pilot bearing???
 

·
Registered
Joined
·
37 Posts
Discussion Starter #6
Replaced it with a South Bend 1944 OFEK, included flywheel, pressure plate, new kevlar pilot bushing, and new throw out bearing.
 

·
Registered
Joined
·
2 Posts
I am having a similar issue with mine. I just replaced with a luk clutch kit but I had allready replaced flywheel with solid years ago. this time I had that flywheel turned and had a new ring gear placed on it. I would like to now what you find out because mine is vibrating now and I think it is due to replacing the ring gear. let me know what you find out.
 
1 - 7 of 7 Posts
Top