Ford Power Stroke Nation banner

1 - 9 of 9 Posts

·
Registered
Joined
·
224 Posts
Discussion Starter #1
ok i replaced my hpop and pressure tested it and no leaks and still it wont start after cranking about 10 times any help would be great
 

·
Fixing Broken Stuff
Joined
·
2,078 Posts
What Is you ICP? I"m guessing from your screen name you have a 06, did you change the fitting (SCT) that connects the HPOP to the feed tube? And what codes do you have now?
 

·
Registered
Joined
·
224 Posts
Discussion Starter #5
Yes its an 06 and cranked till it said tbc fault and yes changed to the updated stc fitting and the only code was a p2285 icp so shoukd I replace that also wasn't throwing that code before I replaced the hpop
 

·
Hood Rich
Joined
·
2,873 Posts
Eh, not so much... Leave it. You obviously have another issue, a dummy plug or feed tube.... jack the truck up in the front as high as you can go safely... let it sit for a few minutes... than start cranking. Pending condition of your batteries and starter, longer cranking is necessary...

You must have pulled your IPR wen you changed this, how did the screen look?
 

·
Hood Rich
Joined
·
2,873 Posts
obviously you said your pressure testing, how are you controlling the IPR when doing this?
 

·
Registered
Joined
·
520 Posts
On the lines of pulling the IPR, did the screen actually come out with IPR or did it stay in the HPOP?
 

·
Registered
Joined
·
224 Posts
Discussion Starter #9
it was a new pump and ipr i ended up getting an icp sensor and two cranks later it was running thanks for all the help everyone i cant believe how much smoother it runs and idles now my stc fitting must have been leaking for a long time cause the truck is running great
 
1 - 9 of 9 Posts
Top