Ford Power Stroke Nation banner

1 - 11 of 11 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter #1
Guys
I am hopping some one could give me an opinion on a issue that has come up
I have a 2009 f250 PSD with an Icon 2.5 level kit. I have been running for about 15,000 miles with no problems at all. Just in the last few days I have come up with a nasty wobble in the front end. It seems like at about 40 - 45 miles per hr if I hit any kinda bad spot in the road or any kinda bump the truck starts to shake violently. The first time it happened I thought I blew out a front tire cause it just went nuts. every thing looks OK under there but
there is definitely some thing in bad shape. I am working in a remote oil field location right now so I cant get it into a dealer. I was wondering if any one had this happen or had any ideas so I could order some parts and get this fixed up my self out here.:psn:
 

·
Registered
Joined
·
421 Posts
^ :whs: Get it fixed asap, your front end will wear out very fast if you keep getting death wobbles while driving. A bad tie rod end can turn into all new tie rod ends and tie rod, and all 4 ball joints.
 

·
Registered
Joined
·
78 Posts
Discussion Starter #5
I think I found the problem I have ordered a new tie rod end I am not 100% sure if it is the problem one but it is loose in my opinion. I am going to change it out today. Any one know any tips on changing out a tie rod I am going to be doing this on the ground at a drilling location. So not really the best circumstances
 

·
Registered
Joined
·
78 Posts
Discussion Starter #6
I think this is the problem (not a picture of my truck) but a visual in case some one has a tip on changing that bad boy out

 

·
Registered
Joined
·
378 Posts
Removed the cotter and the nut. Take a decent size hammer and hit the end in a downward direction. Mine came off with no problem by doing this. Probably a good idea to measure some part of the front end so you dont mess the toe in up to much.
 

·
Registered
Joined
·
78 Posts
Discussion Starter #10
I changed out the tie rod and had an alinement done today. Still the same bad a$$ wobble. The guys at the alinement shop put it back on the rack and we started looking at things more. Found about 1/4 inch play in the steering box. And little play in the Icon pan rod bar. We adjusted the steering box and were able to take the play out of that, but couldn't do any thing with the pan rod being Saturday and no one around here has the bushing. The steering is as lose as a 45 year old party girl now but the wobble seems to have gone. Any one ever have a steering box go on them ?? I hope this solves things for me cause I got to make a 1100 mile drive tomorrow and Monday. And I am a little nervous about making that drive now
 
1 - 11 of 11 Posts
Top