Ford Power Stroke Nation banner

1 - 12 of 12 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Looking at a cheap 04 6.0 it is having issues cylinder 2 and 4 aren’t firing off injectors smokes white, Injectors buzz test but don’t fire fuel into the piston, guy says it has new injectors truck has a hpop leak truck is studded and deleted guy put 7k into it what do you guys think it could be should I buy it
202649
 

·
Registered
Joined
·
5 Posts
Remove oil fill cap, start engine and see if it’s huffing smoke. A slight amount of steady smoke is ok(not enough to feel when hand is an inch or so above filler neck. If it has a pulsation to it or has enough volume to feel blowing then leave it alone, dusted cylinders or worse. Possible rocker arm issues also, pay attention to the rhythm or the engine spinning over before it starts. It should sound fairly even as each cylinder makes its compression stroke, if low compression you will hear an off beat.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Has zero
Remove oil fill cap, start engine and see if it’s huffing smoke. A slight amount of steady smoke is ok(not enough to feel when hand is an inch or so above filler neck. If it has a pulsation to it or has enough volume to feel blowing then leave it alone, dusted cylinders or worse. Possible rocker arm issues also, pay attention to the rhythm or the engine spinning over before it starts. It should sound fairly even as each cylinder makes its compression stroke, if low compression you will hear an off beat.
Remove oil fill cap, start engine and see if it’s huffing smoke. A slight amount of steady smoke is ok(not enough to feel when hand is an inch or so above filler neck. If it has a pulsation to it or has enough volume to feel blowing then leave it alone, dusted cylinders or worse. Possible rocker arm issues also, pay attention to the rhythm or the engine spinning over before it starts. It should sound fairly even as each cylinder makes its compression stroke, if low compression you will hear an off beat.
had zero blow by perfect compression and it cranks even no skip or stutter
 

·
Registered
Joined
·
5 Posts
Well, if you know it has “perfect compression and it passed the injector click test then it is gonna be the injector(s). Being the front two cylinders on the same bank added to that the fact that the Front of the engine is up hill if on level ground and not having suspension issues. Could be combustion getting into fuel rail, or just bad injectors.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
Well, if you know it has “perfect compression and it passed the injector click test then it is gonna be the injector(s). Being the front two cylinders on the same bank added to that the fact that the Front of the engine is up hill if on level ground and not having suspension issues. Could be combustion getting into fuel rail, or just bad injectors.
Passed click test, injector 2 and 4 were replaced but they still aren’t getting fuel
 

·
Registered
Joined
·
201 Posts
Passed click test, injector 2 and 4 were replaced but they still aren’t getting fuel
2 & 4 are the first 2 fed with fuel (on that bank), if they're not firing fuel, it's the injectors, harness, or a sealing issue, I guess it could be hpo leaking or bad pump. Are you sure there's no fuel in the oil or coolant bottle? You can also do the bubble test to check for injector leaks.

Sent from my Redmi Note 9 Pro using Tapatalk
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
2 & 4 are the first 2 fed with fuel (on that bank), if they're not firing fuel, it's the injectors, harness, or a sealing issue, I guess it could be hpo leaking or bad pump. Are you sure there's no fuel in the oil or coolant bottle? You can also do the bubble test to check for injector leaks.

Sent from my Redmi Note 9 Pro using Tapatalk
No coolant bottle is clean checked out on the bubble test
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
2 & 4 are the first 2 fed with fuel (on that bank), if they're not firing fuel, it's the injectors, harness, or a sealing issue, I guess it could be hpo leaking or bad pump. Are you sure there's no fuel in the oil or coolant bottle? You can also do the bubble test to check for injector leaks.

Sent from my Redmi Note 9 Pro using Tapatalk
Apperantly there is a little bit of air in the fuel system
 

·
Registered
Joined
·
5 Posts
Yes and hpop leak
So a failed “bubble” test also denotes a high pressure oil leak? Not sure how that would work. 2&4 as stated I. My original reply are uphill......that’s where the air goes, they do receive fuel first, as well as air or combustion gasses( kinda same but different). He says it passed click test, test is mostly useless unless you actually listen and count off each injector 1-8. Should have a clean sharp sound with pretty close to same amplitude as others.
 

·
Registered
Joined
·
201 Posts
So a failed “bubble” test also denotes a high pressure oil leak? Not sure how that would work. 2&4 as stated I. My original reply are uphill......that’s where the air goes, they do receive fuel first, as well as air or combustion gasses( kinda same but different). He says it passed click test, test is mostly useless unless you actually listen and count off each injector 1-8. Should have a clean sharp sound with pretty close to same amplitude as others.
Yeah, fix the injector problem first (you know you have a leak) then go from there.

Sent from my Redmi Note 9 Pro using Tapatalk
 
1 - 12 of 12 Posts
Top