Ford Power Stroke Nation banner

1 - 20 of 31 Posts

·
<< wasted fuel >>
Joined
·
1,566 Posts
Discussion Starter · #1 ·
i have a water sep. inbetween my tank and pump and a 2 mic napa fuel filter (3528) after my walbro. problem is i have went through sevral fuel filters, a few wix and 2 napa fuel filters with 2 new base's and every one has leaked in the same spot. anyone ever had this problem with the napa base's?

i am getting another new base and filter on warrenty in the morning for the seventh time.

any one have any ideas as of what could be causeing this?





TIA!!
 

·
A Ghost these days...
Joined
·
2,434 Posts
i have a water sep. inbetween my tank and pump and a 2 mic napa fuel filter (3528) after my walbro. problem is i have went through sevral fuel filters, a few wix and 2 napa fuel filters with 2 new base's and every one has leaked in the same spot. anyone ever had this problem with the napa base's?

i am getting another new base and filter on warrenty in the morning for the seventh time.

any one have any ideas as of what could be causeing this?





TIA!!
Without seeing it.... Id try putting a small o-ring on the base threads, then screw your filter on. Some filters come with the o-ring, some dont. I'd try it though.

Good Luck.
 

·
FORD..THE ROCK CRUSHER
Joined
·
2,350 Posts
are you getting the gasket on the filter wet with diesel before you put it on??? or is it leaking some other place??
 

·
<<< THE GAUGE WHORE...
Joined
·
12,082 Posts
No issues here... I have a leak, but its from one of my hoses... I call it rust prevention...
 

·
<< wasted fuel >>
Joined
·
1,566 Posts
Discussion Starter · #5 ·
Without seeing it.... Id try putting a small o-ring on the base threads, then screw your filter on. Some filters come with the o-ring, some dont. I'd try it though.

Good Luck.

yea the first two came with the small o ring for the base threads, but was worse with it.





are you getting the gasket on the filter wet with diesel before you put it on??? or is it leaking some other place??


and yes, i also fill the filter before spining it on...
 

·
Registered
Joined
·
561 Posts
Where's the leak?
 

·
FORD..THE ROCK CRUSHER
Joined
·
2,350 Posts
:whs:

are you using filter base napa part #4770


i never had a problem with mine ether
 

·
<< wasted fuel >>
Joined
·
1,566 Posts
Discussion Starter · #9 ·
:whs:

are you using filter base napa part #4770


i never had a problem with mine ether



yes that is the base i am using and i used liquid teflon sealer on the threads.

it seems to be leaking inbetween the filter and base. i have it mounted on the outside of my frame rail and i noticed that is is just leakin on one side cause i can see where it has blown fuel on the frame and no where else.




ill try and get a pic of it....
 

·
A Ghost these days...
Joined
·
2,434 Posts
yes that is the base i am using and i used liquid teflon sealer on the threads.

it seems to be leaking inbetween the filter and base. i have it mounted on the outside of my frame rail and i noticed that is is just leakin on one side cause i can see where it has blown fuel on the frame and no where else.




ill try and get a pic of it....
I don't use any sealer on my filter threads and never have a problem. I probably wouldn't put any on the new base this time around...
 

·
OEM Moderator
Joined
·
9,379 Posts
As I recall on mine I lightly hit the threads with a tap to clean them up also touched up the gasket surface a bit with some fine sandpaper.


Tom
 

·
Registered
Joined
·
928 Posts
I just installed one post pump and it seeps around the seal also. The sealing surface was a bit rough but I smoothed it out before installing. I hate leaks. Will try the larger filter maybe ease some restriction through the filter.
 

·
green member
Joined
·
297 Posts
Any clue on the pressure ratings of the filters and bases in use? ANd what pressure and flow is that 2 micron rating at?

Assuming the leak is on the pressure side.
 

·
Registered
Joined
·
561 Posts
Are they o-ring land sealed fittings or NPT fittings in those filter heads?
 

·
Village Idiot
Joined
·
8,209 Posts
I do a light film of oil or fuel on the gasket. And spin it down. Your not going grape ape on it tightening it are you.
 

·
<< wasted fuel >>
Joined
·
1,566 Posts
Discussion Starter · #16 ·
I do a light film of oil or fuel on the gasket. And spin it down. Your not going grape ape on it tightening it are you.


no, spin them hand tight and the about another full round.
although i have snuged the last two filters with a wrench in effort to slow or maybe stop the leak.:confused:



the napa guy said he didnt have any on the shelf and if he did he wasnt going to sell me another one anyway because the base wasnt the problem that i was running too much fuel prssure with a walbro.
so ill have to wait on parts city to order one and they said the warehouse showed none. so it looking like monday.




Any clue on the pressure ratings of the filters and bases in use? ANd what pressure and flow is that 2 micron rating at?Assuming the leak is on the pressure side.

i could not get that information.........
 

·
A Ghost these days...
Joined
·
2,434 Posts
because the base wasnt the problem that i was running too much fuel prssure with a walbro.
I wouldn't think that would be the case.

Is your pump getting super hot after driving? Whats your fuel pressure set at?
 

·
<< wasted fuel >>
Joined
·
1,566 Posts
Discussion Starter · #18 ·
i havent checked to see if the pump is getting hot, and i have my fuel pressure set at 65psi.
 

·
Registered
Joined
·
561 Posts
I wouldn't think 65 would be a challenge.
Check the filter you have- See what it recommends tightening wise. If it recommends a half turn after snug, only do that. And see what it gets you.
Overtightening can warp the aluminum a bit, distort the filter case, or even sometimes pulls threads slightly.
Most oil filters say anywhere from a quarter to half turn once snug by hand (snug not meaning double-fist grabbing twisting as hard as you can before you finish with a wrench)
 

·
6.4's are my Hero.
Joined
·
2,058 Posts
I've had that same filter,base, pump setup for about 2 years with absolutely no leaks at all. Watch I go out tomorrow and it leaks! haha.
 
1 - 20 of 31 Posts
Top