Ford Power Stroke Nation banner

1 - 2 of 2 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
This is strike 2 for the lovely towboss

when we left for wd40's neck O the woods weds before last, about 10 miles down the highway i had to brake very fast for a power truck that jumped out on the road, she down shifted very hard and the engine fan spun up like it was going to take off and sure enough the infamous CEL came on, the rest of the trip up to AR she ran great
pulled 13 mpg at 66 pulling the Rv. ran great, pulled excellent, used cruise 99% of the trip. very pleased

left AR made it to Memphis, power started to fall off some and I chalked it up to the RAIN and WIND

got to North Bama and she started doing dumb stuff
tranny ran hotter than normal 200 F, wouldnt hold speed in cruise without some harrowing downshifts, which ran her up near 4k RPMs

then at the nice rv park on the arsenal she started taking a bit longer to start, like 20 seconds, did this 3 x in as many days.
again i chalked it up the massive rain storms we were in, and the current RAIN that followed us to huntsville, maybe a connector was wet or something, gave a good once over but nothing pooped out except one loose IC boot clamp, not off just loose and oil level had increased some ???

then south bound through the very scenic Natchez trace she ran a bit hot and took longer to start at each stop we made to see artifacts and burial mounds etc. Again i chalked it up to it was HOT, and humid plus lots of starts and very little actual road time.

then at a very nice spot in the woods off any beaten path, except for snakes and lizards she decided to take a REAL long time to start, almost to the point i was afraid a dead battery was next


finally got her to start and it was like a gallon of fuel was in there and she caught and revved up real high and made lots of black smoke for a few seconds...

Well we made it to Vickburg ( rain again ) and stayed at a little rv park, the Mrs took the boss to wally world for some rations and yep old girl wouldnt start.

Just as i am leaving with umbrella and large hammer she calls and its running

we decided to get her back and hook up and leave early for home and get to my mechanic that i trust. So old girl didnt get shut off for about 12hrs
the run back we netted 8 mpg at barely 65 and power was so bad it downshifted on each overpass, tail pipe is black as coal and wet.
i dropped her off last monday


she has been under the knife all week
hopefully she comes home on monday
so far its a new hpop line and kit, egr, egr cooler and one injector
 

·
Registered
Joined
·
2,085 Posts
Get rid of that EGR cooler, they are nothing but a pain and waste of money. Spend the money on a kit once, problem solved.
 
1 - 2 of 2 Posts
Top