Ford Power Stroke Nation banner

1 - 20 of 47 Posts

·
Third Member
Joined
·
221 Posts
Discussion Starter #1
I filled the hpop with oil and filled the engine crankcase. Started turning the motor over and checked the fuel level in the bowl. It filled up and the oil pressure on the gauge came up. The high pressure oil is a little above 3500 psi. It set a code of P0344, cam sensor cicuit intermittent. So I pulled the new gray cps and put in my blue one that was working fine when I pulled the motor. It turns over for awhile and then starts hitting like it's want's to start but doesn't. When it does this it's rough. What should I do?:confused:
 

·
Registered
Joined
·
6,652 Posts
3500PSI!!!! Just cranking?

That's WAAAAYYYY too high!

Sounds like your IPR is stuck CLOSED. Remove and clean it, one sec and I'll get you the instructions.

What is IPR Duty Cycle% ?
 

·
Third Member
Joined
·
221 Posts
Discussion Starter #4
Duty cycle I think was about 55%
I have the instructions for the IPR.
Think that's what I should do?
 

·
Registered
Joined
·
6,652 Posts
I really do. Unless you can find another reason ICP is so high, just cranking.

Maybe try unplugging the ICP sensor, maybe it's wigging out, and that's super easy.

If it doesn't start or change after unplugging the ICP sensor though, I would remove / clean / replace the IPR.
3500 while cranking is rediculously way too high.
 

·
Third Member
Joined
·
221 Posts
Discussion Starter #6
I'll go try unplugging the ICP first and see what it does.
Thanks
 

·
Third Member
Joined
·
221 Posts
Discussion Starter #7
I unplugged the ICP. Still no start.
Injector Control Pressure 2465 psi
Injector Pressure Regulator 36%
Those numbers are while cranking.
 

·
Corona Killa
Joined
·
1,727 Posts
when I installed orings on some injectors in my dads truck when I tried to start it after it did what yours is doing and all I did was let it sit and run ruff then ran it at 2200 rpms tell it seemed better then drove the snot out of it to get the air out of the oil.
 

·
Third Member
Joined
·
221 Posts
Discussion Starter #9
Mine won't start. It acts like it wants to but it won't.
 

·
Corona Killa
Joined
·
1,727 Posts
It turns over for awhile and then starts hitting like it's want's to start but doesn't. When it does this it's rough. What should I do?:confused:
When I read that I thought it would run but just ruff. Have u ran a buzz test or anything on the injectors maybe check the VC harness also.
 

·
Third Member
Joined
·
221 Posts
Discussion Starter #11
I ran a buzz test and they all worked.
I removed the IPR and put in another one, out of the other hpop and it still won't start.
 

·
Registered
Joined
·
6,652 Posts
What are the values with the IPR DC% and ICP now that you have the other IPR installed?

You sure you have the right plug in the IPR :poke:
You might have the EBPV actuator plug in the IPR
 

·
Third Member
Joined
·
221 Posts
Discussion Starter #14
I plugged the icp back in when I changed the ipr and noticed the pres. was back up to 3500 psi while cranking. :shrug:I was pi$$ed off enough by then I shut everything off and came inside. I'll try again in the morning and see if anything changed overnight. Maybe Santa will stop by and fix it for me tonight.:smirk:
 

·
Corona Killa
Joined
·
1,727 Posts
hey sometimes that works just leave it alone and it will work later or you'll find the problem right when you start again.
 

·
2010 BOB Points Runner up
Joined
·
2,300 Posts
Are the injs clicking while cranking also? Don't know why they wouldn't, but you have ICP so alls you should need is fuel and elecrical command to fire the injs

-Michael
 

·
Third Member
Joined
·
221 Posts
Discussion Starter #18
The pickup has been sitting in my shed since the end of July. Would the summer fuel have any effect on this? I removed the fuel filter and the fuel looked normal, it wasn't gelled up anyways.

I don't know about the white smoke cause I couldn't see the exhaust while I was trying to start it.

The injectors passed the buzz test so I assume they are working. Can't really hear them over the motor turning over.
 

·
OEM Moderator
Joined
·
9,381 Posts
2465 is an erronous reading for oil pressure. If that was while you had the icp sensor unplugged it is probably OK. I still suggest you use a manual gauge on the head. When you did the buzz test did all of the injectors sound the same loud and strong?
 
1 - 20 of 47 Posts
Top