Ford Power Stroke Nation banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Ive got a 97 7.3 that seems to have a missfire like it's running on 5 or 6 cylinders and has no power and slow throttle response. Has p0603 code ive ohmed all the wiring out to the injectors from idm and have ohmed power and ground to pcm and have also tried a different pcm and im just kinda stumped. Any ideas?
 

·
Registered
Joined
·
2,861 Posts
P0603 is the Keep Alive Memory (KAM) code that comes up if you disconnect the batteries or have a chip (which by-the-way, do you have a chip on it?). Cheers!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Had a chip i took it out still had the same problem talked to local shop he thought maybe idm or injectors? Just seems like an injector wouldnt go bad so fast i shut it off and next time i got in it ran like crap
 

·
Registered
Joined
·
2,861 Posts
I would try running it with the valvecovers off so you can see which injector may not be discharging oil out the discharge spouts. Have you ohmed out the injector solenoids to see if they are all around 3 ohms? You can also check the poppet screw on any offending injector to make sure it is tight (screw is under the solenoid). Cheers!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
So i havent had time to work on it yet but if i dont have oil coming out the dishcharge spouts would that mean that the injector is bad or just not getting power to open?
 

·
Registered
Joined
·
2,861 Posts
It would mean that there is some sort of mechanical problem with the injector (loose poppet screw or an internal issue) or there is an electrical problem (wiring, UVCH, solenoid, etc). Cheers!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Alright so i put a new idm in and the thing runs great starts good but seems like it cranks a little longer than before. Could that just be the way the new idm is? Or possibly an hpop leak, i know i dont have any external hpop leaks.
 
1 - 7 of 7 Posts
Top