Ford Power Stroke Nation banner
1 - 7 of 7 Posts

·
Registered
Joined
·
326 Posts
Discussion Starter · #1 ·
Came out to lunch one day and started the truck. It is missing on what seems to be 2 cyl, but could be 1, hard to tell. Put it in gear and the truck is shaking, but by the time I got out of the parking lot it was running perfect again. I thought it was odd, but it's the first time I did it so I didn't think too much about it. Well, about 2 weeks later (last night) I bought a camper and towed it from the dealer to a parking lot about 5 miles away for a pit stop. When I start the truck back up, it is idling rough again. Light acceleration in the parking lot it's pretty shaky but I couldn't tell if it was 1 or 2 cyl down. Once I pull out onto the road it's running smooth again and the rest of the night it's perfect. Is this just a glow plug not heating up right until I get a little warmth built up or something else? It's only happened the two times, and both times once I get on the main road it fixes itself. Once when cold, and once when warm. Ideas?
 

·
Registered
Joined
·
270 Posts
After it's been up to speed and/or warm, if you just sit and idle, do you notice any miss at all without "rough" idling?
 

·
Registered
Joined
·
326 Posts
Discussion Starter · #3 ·
After it's been up to speed and/or warm, if you just sit and idle, do you notice any miss at all without "rough" idling?
Nope, it always purrs like a kitten hot, cold, for as long as you want. I've only noticed this happen twice upon startup. Once after setting for about 5 hrs, and this last time after sitting about 10 minutes.
 

·
Registered
Joined
·
270 Posts
Try running some RevX, Monster Diesel, or Cetane in your next tank. See if that makes a difference. If you're not throwing any codes, and it seems to be self limiting, I wouldn't worry too much. But, if the diesel additive doesn't help, then you might want to take it in for an actual diagnostic.
 

·
Registered
Joined
·
326 Posts
Discussion Starter · #5 ·
I haven't put anything in it yet, but it did it again today. I started it up and let it idle for about 10 minutes. It was missing from startup. It sounded pretty rough, had a louder clatter to it. When I drove it this time, the miss never went away. I still had the camper hooked up so I could definitely feel it. Drove about 10 miles, shut it off for about 5 minutes. When I restarted, it was still missing, but not as bad. Within a mile it had cleared up and it ran great again. I'm not sure what shutting it off for 5 minutes had to do with it, but that was what it took this time to clear it up. I'm not a diesel wiz, bit it acts as if a glow plug is fouled, and re-starting, re-up it. It's kinda got me baffled, but I plan to add some cetane or similar tomorrow.
 

·
Registered
Joined
·
270 Posts
Well, that sounds like it's definitely worsening. Cetane or other additive for sure (won't hurt), but I think I'd get a diagnostic to see if something else is going on like glow plug, etc. Not sure.
 

·
Registered
Joined
·
326 Posts
Discussion Starter · #7 ·
It hasn't done it again since, but I added come cetane the other day just as a preventative measure. Today I got the CEL, pulled the codes and got P0128 and P0266. P0128 I have got before and is just thermostat performance. I've had it pop up a couple of times in a year, just clear it and go again. Thermostats are working, it just happens if I idle for too long so it doesn't warm up. The P0266 is for cyl 2 contribution/balance so at least I know what cylinder was causing the issue. After reading some others experience, I at least know why/how the code was set and I'll keep an eye out for it going forward. The truck is running perfectly and I just got back from a weekend of camping. Towed the 36ft 5th wheel and the ski boat behind. Guessing the overall trailer weight at about 14k lbs. The truck couldn't have performed any better. I don't think I ever even went past half throttle, didn't have the need. :)
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top