Ford Power Stroke Nation banner

1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Did the cat and DPF delete straight pipe and installed the Mini Maxx tuner. Ran through the setup on the tuner and started the truck now it's in limp mode and screwed. I've reset the turner to defaults and tried again and nothing works. I'm at a loss. What could be wrong? Check engine light is also on.

2008 F450 w/ 6.4
 

·
Registered
Joined
·
6 Posts
Discussion Starter #2
Did the cat and DPF delete straight pipe and installed the Mini Maxx tuner. Ran through the setup on the tuner and started the truck now it's in limp mode and screwed. I've reset the turner to defaults and tried again and nothing works. I'm at a loss. What could be wrong? Check engine light is also on.

2008 F450 w/ 6.4
I'm throwing 4 codes

P0750
P0755
P0765
P0770
 

·
Registered
Joined
·
77 Posts
Those are all transmission Solenoid circuit open failures, Check the wiring from the TCM to the Transmission or possibly the transmission tuning is corrupt.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Pulled the trans dip and it's brown and has particles of dirt. Draining / dropping the pan and inspecting solenoids. May ohm test them to make sure they're operating correctly. Once it's back together I'll see if codes are still there. Gonna be a fun day.

I reinstalled the OEM settings on the ECU and the solenoid codes were there along with the missing oxygen sensors. This confirms its the transmission and not the tuner, IMHO. The oxygen sensor codes were not present with the tuner installed.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Pulled the A solenoid out and it tested within range. Crap.
Installed pan and refilled with fluid. Runs fine but wrench code still exists. Still DOA.

Must be the Trans tune on the mini Maxx.

No clue where to go from here.
 
1 - 8 of 8 Posts
Top