Ford Power Stroke Nation banner

1 - 14 of 14 Posts

·
Registered
Joined
·
176 Posts
Discussion Starter #1
ok so have gone through 4 mechanical piumps in 3 months, now i was running vegitalble oil and i might have #### in the tank no i havent ran any since i stuck the 1st new pump in there. ok i have been told that there is pumps in the tank ok if thats true the is there sock on the pumps like in a gas truck. im gonna drop my tanks and clean every thing. i can only imagine what is in there. if u guys know about the tanks and the fuel pump in the tank pls let me know thanks so much for ur help.
 

·
Registered
Joined
·
797 Posts
Re: mechanical fuel pump probiblems

There are no pumps in the tanks.
 

·
OEM Moderator
Joined
·
9,381 Posts
Re: mechanical fuel pump probiblems

There is a screened filter umbrela for a pickup.
 

·
What else?
Joined
·
4,156 Posts
If you poured vegetable oil directly into your stock tanks, with no modification to your stock fuel system, the tanks and possibly the rest of the system have the oil partially clogging everything.

It must be heated to properly flow through the system.

You are correct that you'll have to drop the tanks and clean out everything, fuel lines and all. Stock mechanical and electric pumps cannot pump room temperature veggie oil, even on a hot summer day.

I've had to clean my Dad's fuel system out because his veggie oil system messed up, letting unwarmed veggie oil into the fuel lines, it sucks. Good luck.

Dave
 

·
Registered
Joined
·
176 Posts
Discussion Starter #6
thanks for all the help guys i appericate it. i looked it up on all data and it didnt say anything about a screen so thanks and im not looking forward to cleaning it... lol lesson learded no more oil unless its heated... thanks gain
 

·
Registered
Joined
·
797 Posts
Since you've got both tanks to do, it'd probably be easiest to take the bed off (only a few bolts and a few electrical conenctions) then you can take the pickup assemblies straight out, without dropping the tanks.

On second though though, if you've got to rinse the tanks out...well looks like you're dropping them after all. Nevermind!!
 

·
Registered
Joined
·
176 Posts
Discussion Starter #8
i did it and it turned out good. got alot of nasty stuff outof the tanks. i allso added a mr.gasket diesel fuel pump low psi pump in front of the front tank to help as a pusher pump seems to be fine what do u guys think about that
 

·
What else?
Joined
·
4,156 Posts
If you're still using the mechanical pump it's not going to help at all, as your stock pump is a 2 stage pump, with a diaphragm on the low pressure side, and a piston for the high pressure side.

It can't pump anymore with a few psi of pressure on it, if anything, you may blow the diaphragm out on the low pressure side, as it was only designed to see vacuum. Just my .02.

Dave
 

·
Registered
Joined
·
176 Posts
Discussion Starter #10
still having fuel issuies

ok so i added a little mr gasket eletric diesel pump in on my stock fuel system and im still having probiblems. i dont understand and am extremly pissed. the whole fuel system is clean and it still is having probiblem. if the hpop was going bad could that have anything to do with this or what. ive got to get it running again. what it does is it sounds like the filter is clogged and the injectors start ticking then it dies and it will fire on eather but wont run... need ideas. cause im done with it. its about to get a cummins and be done with powerjokes. but the truck has 295 on it cant complain to much... lol
 

·
Registered
Joined
·
344 Posts
Your pissed at a truck that your trying to stuff french fry oil down it's neck? :pointlaugh:

Seriously... Now as to your problem. Are you cutting the VO with anything to thin it out? or running it straight unheated? If unheated you will have a hard time trying to pump VO into the engine at 100%. Try cutting it to at least 70% Vo to diesel. Then run the rear tank 100% diesel. About 5 mins before you shut the truck down switch to the rear tank to purge the VO out of the filter and the pump. If you decide to run a heated system don't heat the VO to anything higher than 120 degs. F it starts to loose it lubricating property after that
 

·
Registered
Joined
·
176 Posts
Discussion Starter #14
i was mixing it with diesel. i was running 5 gallons of oil to 15 gallons of diesel. but im trying to run my truck on just diesel now and that is what im having probiblems with. i have cleaned the fuel system from back to front except the hpop that is still original. what are indications when a hpop is going bad or does it just stop. im sure its tired
 
1 - 14 of 14 Posts
Top