Ford Power Stroke Nation banner

1 - 18 of 18 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Anyone know what would cause the engine temp guage(stock) to take for ever to climb up to normal, almost 12-15 min, after start up. Trans temp jumps right up.
After a few replacement problems (FICM, Fuel leak) i may be paranoid. Oh yeah, average outside temp is 39-45 degrees. thanks,
 

·
Keep er shinny side up!
Joined
·
1,624 Posts
Colder air temps? First winter with the truck? 12-15 minutes doesn't really seem that bad to me, but is that driving or idling?
 

·
Registered
Joined
·
18 Posts
Discussion Starter #3
Not really colder, they have been bouncing up and down over the last two weeks. I can start the truck and after about 10 min of idling, i have to leave for work. It gradually climbs on the 10 min ride in..still not to normal. started about a month ago. When it does finally go up, its at the normal range between C/H. I plan to get guages install after the holidays. Kids broke me..lol
 

·
40 lug nuts
Joined
·
3,433 Posts
I think it could be one of two things: either an issue with the gauge (and I don't put a lot of faith in the factory gauges -- they're not very accurate) or an issue with your thermostat.

First step would be to verify that the truck is in fact taking longer than it should to warm up and what you're actual temperatures are.

Personally, I wouldn't worry too much if I was in your shoes and the truck seems to be running well otherwise.
 

·
Super Moderator
Joined
·
3,401 Posts
Using my CTS it takes about that long to get to normal temps while driving.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #7
I'll definately keep an eye on it now. I'm making a 500 mile trip to florida tomorrow, just don't want to go dead in the middle of the trip this close to Christmas.. Thanks for the info
 

·
Registered
Joined
·
18 Posts
Discussion Starter #8
Oh, i did just have to change the FICM and install a Fuel Pressure regulator kit, due to a leak. don't think those could cause temp changes.
 

·
Registered
Joined
·
29 Posts
Get an actual temperature gauge (ScanGauge, mechanical, Edge CTS, whatever) that will tell you the actual temperatures, the stock gauge is little more than a dummy light.
 

·
40 lug nuts
Joined
·
3,433 Posts
I'll definately keep an eye on it now. I'm making a 500 mile trip to florida tomorrow, just don't want to go dead in the middle of the trip this close to Christmas.. Thanks for the info
I don't think this, if it is an issue, is related to the other problems you just fixed. To be honest, I'm not even sure it's a problem.

As mentioned, you can pick up a Scangauge for pretty cheap at AutoZone, Advance Auto, Pep Boys, etc and this will tell you what your actual temps are (in addition to monitoring a whole bunch of other parameters).

Where in FL are you going?
 

·
Registered
Joined
·
18 Posts
Discussion Starter #12
Fort Walton Beach area, NW panhandle...
 

·
Registered
Joined
·
18 Posts
Discussion Starter #13
its official, getting guages. ran it afterwork, heated up in about 20 mins, heater works fine, hot enough in about ten minutes, ambient air 55*.... love this truck...
 

·
Registered
Joined
·
474 Posts
Neither of those things has to do with the coolant tepm. I can tell you this, diesels in general take longer to warm up and for some reason all the guys I know including my truck won't warm up for nothing just idling. This is what a high idle switch is for.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #15
when you say high idle, are you refering to hooking it up to the upfitter switches. I have a high idle that kicks in about 2-3 mins after starting. I can hit the brake and it shuts down to normal.
 

·
Administrator
Joined
·
32,960 Posts
thats the OEM high idle strategy kicking in but you can go Higher with the High idle mod
there are actually a few choices on how to do it
 

·
Registered
Joined
·
221 Posts
Not really colder, they have been bouncing up and down over the last two weeks. I can start the truck and after about 10 min of idling, i have to leave for work. It gradually climbs on the 10 min ride in..still not to normal. started about a month ago. When it does finally go up, its at the normal range between C/H. I plan to get guages install after the holidays. Kids broke me..lol
Buy a scan gauge 2 to find out what the actually numbers are. It could be the gauges going a little nuts or it might be the sensors.
 
1 - 18 of 18 Posts
Top