Ford Power Stroke Nation banner

1 - 7 of 7 Posts

·
Registered
Joined
·
110 Posts
Discussion Starter #1
ok my truck just recently after pulling a car on a trailer started burning oil bretty bad. it went through 6 qts in a week. my buddy who used to work at international said it may be my injector o-rings or the internals of the injectors thats causeing it to burn it. but i just put in used injectors before winter so i would think the o-rings would be good since i replaced them with new ones. also i have the 10k resistor mod on my truck and when i take tghe resistor out now the truck lopes real bad and has no power. so it pretty much wont run without the resistor in now. i have it set up for my old set of injectors to get rebuilt by jim at the end of the month but i just want to be sure (or as sure as i can be) that it is the injectors. this truck doesnt leak so its not leaking any out.
thanks!
 

·
Registered
Joined
·
1,578 Posts
Possible it could be orings. Check the fuel bowl. If the fuel in there is black then you need orings
 

·
Registered
Joined
·
110 Posts
Discussion Starter #3
yea the only problem about checking the fuel bowl is that i run waste motor oil and transmission fluid with fuel so the filter is already colored black lol
 

·
Registered
Joined
·
1,578 Posts
Haha. Well that rules that out
 

·
Registered
Joined
·
682 Posts
Does it smoke bad?

Using that much oil it has to be smoking. Do you have oil in the ehxaust? could be the turbo.
 

·
Registered
Joined
·
1,216 Posts
The resistor mod is upping the ICP pressure, that is why when you take it off it lopes. You need new injector o-rings.
 

·
OBS Addict
Joined
·
1,538 Posts
:whs: I dint like the resistor mods simply because of this. To risky. Should just stick to tuning IMO. Good luck.
 
1 - 7 of 7 Posts
Top