Ford Power Stroke Nation banner

1 - 20 of 260 Posts

·
Registered
Joined
·
3,357 Posts
Discussion Starter #1
okay so here's the story.
We have been after a diesel Excursion for some time.
In order to get one I had to sell my beloved 2000 F250 V10 superduty Lariat flatbed (73K original miles, was my dads since new)
So I could not let my flatbed go until I had a replacement hauler
I am building up a 97 OBS 4 door 7.3 F350 to become my new hauler/base of operations.

So I posted the Superduty flatbed for sale. I was asking $10K firm.
I had 8 interested parties!! WHOA!! I did not expect this. Must have too low of a price. Anywho first kid to come see it and drive it wanted to buy it, but he had to go finish his loan approval so he left with a promise to return in two days with $$$$

That night I am considering the truck sold, unless somebody came with a offer over $10K this would be his truck. Well thats when I got a phone call. You see in my add I mentioned I would trade for a 7.3 Excursion.

Well this gentleman had just such a beast. He had bought and fixed up a diesel excursion for his daughter to use taking his grandkids skiing. He spent over $5000 on this truck (maintenance) this year to get it into primo condition. His daughter never drove it, it was just sitting in his barn. Now his daughter was moving and she needed a flatbed truck. Well this man is a huge Ford finatic and he recognized I had a early 6.8L V10 one owner truck with low miles and a flatbed. He offered me trade straight across.
I was floored.

Went to look at Excursion next day and we made the deal, PINK SLIP FOR PINK SLIP!!!!!!! IM A LUCKY GUY!!!!!!!!!!!!!!!!!!!!!!

SO here she is our new to us Excursion, family and toy hauler.

2001 Limited. 7.3L 4x4, 162K miles in PRIMO condition (some hail damage, cracked plastics, dents and scrapes)
Sony bluetooth head until with all Focal speakers (separates in doors), 6" JL sub in custom box. Wicked cool!

Has all new fluids, all new hoses, new radiator, new ac system, all new fluids (I mean all), new batteries, Odyssey brake controller, 5" exhaust with muffler, Pod with Autometer sport comp gauges (EGT Boost, trans) K&N drop in. I have alot of paperwork on this thing. Apparently he wanted his grandkids to be in a very reliable truck, then fell in love w my flatbed.
So we are in love with our new limo bus. While looking it all over I unzipped the spare tire cover only to find a Hypertech programmer from 1990! Whao! Bonus! It works, stage I II and III..SWEET!!!!!!

Sounds like a friggin freight train

What a MONSTER THIS TRUCK IS!!!

And so it begins

First things first, I have a pushbar for this truck I bartered for and intended to put on Superduty. I am now refurbishing it for this excursion

It needs a few little things, overhead grab handle. I need to sew the velcro strap back on for the second row seat folding thing. Plastic cowl piece is busted, trans temp gauge inop.

We are happier then pig in poop with this trade. I will love this beast forever!!!

Bye Bye V10! What a great truck it was
 

Attachments

·
Registered
Joined
·
3,357 Posts
Discussion Starter #2
Thanks Peter!! You are the MAN!!!! We love our truck and wish you the best with yours!
 

Attachments

·
Super Moderator
Joined
·
8,056 Posts
Wow. You got a hell of a deal.
What part of Colorado are you in? I'm just over in grand junction.
 

·
Registered
Joined
·
3,357 Posts
Discussion Starter #4
Hey Neighbor!!

We are in Conifer/Evergreen at 9000' :)

Natives all of us (my wife, stepsons, their wives, my kid and grandkids) one big happy camping wheeling family!!!

Yes we got the SMOKING DEAL of the century!!!! I deal in Ford trucks, it is my main hobby. I design elevators, so when I am not working I am wrenching. I believe these trucks have a final destination the day they were built in the factory. That V10 was meant to be Pete's and this Ex was meant to be ours. She is home!!
 

·
Registered
Joined
·
3,357 Posts
Discussion Starter #5
Any idea how this Autometer trans gage is to be wired?
Does it go to a factory temp sender wire or do I need a probe for auto trans test port (none installed, gauge is inop)

Odyssey brake controller i always on, should I be concerned? add a switch?

vacuum pump out of its mounts, tie wrap time

Saving for headrest DVD system, S&B intake, projector 05+ headlamps
 

Attachments

·
Super Moderator
Joined
·
8,056 Posts
That's a pretty large wire coming off the batt with no fuse.

I have no idea on the gauge or the brake controller. How is it wired? Maybe it's hooked up wrong.
 

·
Registered
Joined
·
3,357 Posts
Discussion Starter #7
that large wire is the amplifier feed under middle seat......... I will add a 0 gauge fuse and holder
You never know what you will get with a used truck!!
 

·
Registered
Joined
·
3,357 Posts
Discussion Starter #8
Update, SLOW START

Normally with this truck you bump the starter and she comes to life
today it was crank and crank then finally start.
Not normal

Also noticed slight bump at idle, if it was a gas engine I would say a slight miss

I suspect CPS? Ordered new one from Allied power
Will check battery voltage tomorrow when we try to start and see if she still has slow start

I have added Dieselclean and a full tank of gas yesterday, now today slow start
We got 650 miles + from our first tank of gas! Overhead console was at 14.3 now after a week of driving says 14.7
My old superduty V10 never went above 11.8!
truck did have cps code when I first scanned it...no CEL
I was surprised to get cps code without a CEL but hey Im totally new to diesels
 

·
Registered
Joined
·
3,357 Posts
Discussion Starter #9
Update this AM NO START

cranks cranks cranks no fire
Battery voltage seems okay
tachometer needle is flat flat flat slight bump flat flat flat flat slight bump flat flat slight bump
while cranking.

CPS? I hope so new one is on its way
It has been raining alot last couple of days, plenty of moisture in the air
Full tank of diesel with half bottle of diesel clean installed.
Started to notice a slight miss at idle last day or two
Those are the only things that have changed from running great til now
no codes in memory (will scan again)
SOB!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! NO START WTF happened?
fun times
DON'T MAKE ME CHANGE THE NAME OF THIS THREAD only one week in!
gotta drive the wifes toyota to take kids to school NO!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
hahaha
 

·
Super Moderator
Joined
·
8,056 Posts
How cold did it get up there last night?
Do you have fuel in the bowl?
 

·
Super Moderator
Joined
·
8,056 Posts
Any smoke out of the tail pipe?
 

·
Registered
Joined
·
3,357 Posts
Discussion Starter #12
I will check for fuel in bowl
NO smoke from pipe (LOL this is Colorado)
It got down to about 45? best guess
getting up to 52 now

NO SMOKE zero zilch
Tachometer needle appears flat, it no longer bumps it just rose about 1/16"
Fuel bowl full nice blue/green diesel (wow my 97 fuel is dark in comparison)

Please teach oh wise one!!
 

·
Super Moderator
Joined
·
8,056 Posts
Do you have the digital or mechanical odometer?
 

·
Registered
Joined
·
3,357 Posts
Discussion Starter #14
Checked weather was 45 low last night up to a brisk 52 right now

let me go check odo 99% sure its mechanical


you do realize I live on the 2nd floor and each time I come back here I have to do the stairs again and of course the truck is parked about 50 yards from the shop and with the nose hanging over a muddy hill!!! HAHAHAHA lucky my ass!!

Seriously thanks for the help
 

·
Registered
Joined
·
3,357 Posts
Discussion Starter #15
mechanical odo

No door sticker on these trucks??? I do not know build date
 

·
Super Moderator
Joined
·
8,056 Posts
So you should have a door sticker. Maybe it was in an accident. Repaint?
So because it has a mechanical odometer. It's an early 01. And it should show rpm. The late 01-03 do not show rpm while cranking.

Sorry for all the one question responses. I'll try and make a few at a time to cut down on the hike.

It could very well be the cps. If it doesn't fix the issue. Try plugging in the block heater and let it sit for 2 or 3 hours. If it starts up you could have injector issues. But I don't think it's that because you don't have any smoke

Do you by chance know the rpms while cranking? It does have the wait to start light right? It got cold enough to make the fuel bowl heater turn on. Voltage while cranking? How old are the batts?
 

·
Registered
Joined
·
3,357 Posts
Discussion Starter #17
Thanks for your help
no door sticker I really do not think this door has been replaced??? There are other stock stickers on the drivers door.
Where is door sticker located on 01 excursion?

CPS will be here tomorrow I ordered two from Alliant via Amazon
Yes it has wait to start light
Batteries seem okay, they will crank and crank no fire
I have not checked voltage

If this was a Ford gas engine I would be testing for spark to confirm the CPS is faulty
When I ran the hypertech programmer it did give me a CPS code, twice during its test proceedure But it also gave me hego and egr codes too that did not repeat.

Would faulty CPS cause a miss at idle?

Thanks man! I have faith
Tacho needle is completely flat while cranking
 

·
Super Moderator
Joined
·
8,056 Posts
Sticker should be on the b pillar below the striker when you open the door.

I would bet it's a cps. I guess you just have to wait and see.
 

·
Registered
Joined
·
3,357 Posts
Discussion Starter #19
Its okay I have plenty to do, we are driving our trail rigs since I traded away our best truck!!!!

So to help me learn (and teach, two stepsons both have 7.3 now):

7.3 no start
1. We check for smoke from tailpipe would indicate injectors are attempting to fire (helps rule out CPS and IDM?, What is IDM exactly injector control computer?)
2. Flat tachometer needle indicates no signal from CPS (PCM has no idea engine is rotating)
3. Full fuel bowl = electronic rail mount fuel pump likely working (is there a boost pump in the tank on these?)
4. Check battery voltage (just because starter turns does not mean will reach sufficient rpm to fire)

What would no wait to start light indicate? bad glow plug relay?
 

·
Super Moderator
Joined
·
8,056 Posts
Smoke from the tail pipe means the injectors are attempting to fire.
The idm is the injector driver module.
2. Right. But doesn't mean that on 01.5-03 trucks. The tach can not move on those trucks while cranking.
3.true. no pump in the tank. But there is some filters that get clogged. Google hutch mod
4.the pcm won't fire the injectors if the voltage drops below 10 volts.
It won't fire the injectors of the rpms are below 100-150? I'm blanking out on that number right now.
5. The wait to start light means the pcm has no power.

Any more questions just ask.
 
1 - 20 of 260 Posts
Top