Ford Power Stroke Nation banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
hi.. i have got a 95 f-350 2wd with the 7.3 turbo.. what the problem is, is that my low range light is flashing on and off, no pattern, and obviously it is 2wd.. i am figuring that there is a wire grounding out or somethin.. aint go in there to look yet just seeing if anyone has had this problem or now where to start looking... also truck is running good no problems just the light..thanks
 

·
STILL LEARNING
Joined
·
18,331 Posts
There should not even be a bulb in that location. Someone has been playing around
 

·
Registered
Joined
·
350 Posts
I've got bulbs in my anti-theft and airbag indicators and neither myself not the 1st owner did it. I've always kind of wondered about that.
 

·
Registered
Joined
·
630 Posts
The indicator bulb for low range has power to it all the time when the key is in the start or run position. It would get it's ground path through the low range switch for the transfer case......if you had a transfer case. It's pin # 11 on the black connector on the back of the instrument cluster. It's a light blue wire with a black stripe. It's either shorted to ground in the cluster or the wire has chafed somewhere along it's run down to the transmission. (It's in the transmission harness even though you don't have a transfer case to plug into it.) You can turn the key on and slowly wiggle the harness along it's length from the back of the cluster down to the trans while someone watches the light, when it flickers you are getting close to where it has chafed. Or you could just take the bulb out. Remember though, it's one wire in a bundle. IF it has chafed out in the harness it's only a matter of time until another wire gets cut.
 
1 - 4 of 4 Posts
Top