Ford Power Stroke Nation banner
1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I have 1997 F250HD with 340000 mi i had this truck since it was brand new. I want to restore the truck but first want to make sure motor rock solid. I’ve rebuilt the stock turbo and the EBV delete no change in power. Dropped the fuel tank found screen broken in pieces cleaned out fuel lines replaced screen currently have 60-65 psi at regulator, no big increase in power. Checked compression on cyl all 360 except #7 340 cold and 350 warm. So I had the stock injectors rebuilt to 160/0 and replaced all glow plugs and EOT sensor noticed a change in how fast it spools up little more power too. I pulled for the first time a small tractor hardly any power. I have a scan tool for iPhone no codes. Icp gets up to 2400-2500 wot , oh and blueish white smoke when rev high. Truck runs better once warmed up seems like. I live in Louisiana so no cold issues. Only sensors that have not been changed are the icp , IPR . Any ideas would be greatly appreciated.
 

·
Registered
Joined
·
3,258 Posts
Do you have tunes to go with the injectors? Even though they will flow more fuel, you need the tunes to do it. Cheers!
 

·
Registered
Joined
·
1,347 Posts
Do you have a tuner? Look at the PHP Hydra. It is the latest tuner for the 7.3. It does not "reflash" the PCM memory so you avoid the hazards of reflashing. Tunes can be changed on the fly. PHP has canned tunes with fueling set up for different sized injectors. Or you can contact a tuner and have them create custom tunes.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Do you have a tuner? Look at the PHP Hydra. It is the latest tuner for the 7.3. It does not "reflash" the PCM memory so you avoid the hazards of reflashing. Tunes can be changed on the fly. PHP has canned tunes with fueling set up for different sized injectors. Or you can contact a tuner and have them create custom tunes.
The shop that rebuilt my stock injectors told me the 160/0 stage one will run fine on a stock truck. This is why ask my original question thinking that may need to continue troubleshooting.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
The shop that rebuilt my injectors told me the 160/0 stage 1 would run fine on stock truck . That is why I ask my original question based off his opinion. Wondering if I should continue troubleshooting.
 

·
Registered
Joined
·
6,464 Posts
They will run fine but to get more power you need a chip or programmer to supply more fuel to them. With out that programming you are just supplying the stock amount of fuel.

Sent from my SM-J737V using Tapatalk
 

·
Registered
Joined
·
19 Posts
This sounds like a problem I had with my 97, 7.3
I have a boost gauge and I could see that I was not getting any turbo boost above 2-3lbs
It finally came down to a split in the manifold pressure line going up to the firewall-mounted MAP switch.
I found it by putting an air fitting in a 3" ABS pipe cap, that fit perfectly into my intake airline after removing the air filter.
Try to put 10-15 lbs in the engine without it running. If you have an air leak you will find it.
After installing new lines, I have up to 17lbs boost with the stock wheel.
 

·
Registered
Joined
·
373 Posts
Get a tuner of some sort. I went with DP only because he did another one for a different truck never never any issues
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #10 ·
I installed a TS6 pos chip and really woke up the old engine. It throws a cel when I’m in higher hp tunes only if I get into throttle. Gonna watch with my scan tool icp ipr and need to check my fuel psi under load gotta get a test gauge kit.
 

·
Registered
Joined
·
3,258 Posts
What code(s) was/were set? That will narrow down what you need to look for. Cheers!
 
1 - 11 of 11 Posts
Top