Ford Power Stroke Nation banner

61 - 74 of 74 Posts

·
Reppin' the 6.4L
Joined
·
2,341 Posts
Discussion Starter #61
Xtreme Race- VXBC3N2

 

·
FNG
Joined
·
6,018 Posts
Your batteries sound weak as hell in the first vid
 

·
Reppin' the 6.4L
Joined
·
2,341 Posts
Discussion Starter #63
Your batteries sound weak as hell in the first vid
Batteries tested out fine, along with the alternator. The only problem I have is the plug on the alternator. my diesel tech is working on finding a plug from a 6 liter harness at his house to wire in place of mine. Inside of the plug, one of the connectors is a little loose. Whenever we mess with it, the battery light will turn off and stay off for a good while, but it eventually comes back and flashes every once in a while. Could that be causing it?
 

·
Reppin' the 6.4L
Joined
·
2,341 Posts
Discussion Starter #64
I'm a video machine today. Here's a vid with the Xtreme Street tune with lower HPO that Eric sent me.

 

·
FNG
Joined
·
6,018 Posts
Crank it over right when the WTS light goes off once instead of waiting so long
 

·
Registered
Joined
·
706 Posts
Crank it over right when the WTS light goes off once instead of waiting so long
I always thought you had to wait for pretty much any noises to stop, my injectors go then there are 2 noises still left just like in the video??? We can just crank it when the WTS light goes off and disregard any other components still going through the start-up up process?
 

·
Registered
Joined
·
706 Posts
Sickstroke what is that device you have above your head??? And just out of curiousity in the video where your truck started the easiest your oil pressure came right up with your tach... however all other videos oil pressure takes about 2-3 seconds before jumping up,,, why is this as my truck also takes 2-3 seconds before showing it?
 

·
FNG
Joined
·
6,018 Posts
Nope once the WTS light goes off crank it over:D
 

·
Reppin' the 6.4L
Joined
·
2,341 Posts
Discussion Starter #70
Sickstroke what is that device you have above your head??? And just out of curiousity in the video where your truck started the easiest your oil pressure came right up with your tach... however all other videos oil pressure takes about 2-3 seconds before jumping up,,, why is this as my truck also takes 2-3 seconds before showing it?
That's my overhead console without the plastic housing. :doh: Long story short, it shattered. :doh:

And Dave, I thought it was better to let the glow plugs go through their complete 120 sec cycle?
 

·
Ballin' on a Budget
Joined
·
1,396 Posts
That's my overhead console without the plastic housing. :doh: Long story short, it shattered. :doh:

And Dave, I thought it was better to let the glow plugs go through their complete 120 sec cycle?
No. You are just drawing more power doing that. What I do is: On the very first start up I let the glowplugs work for a little bit. The longest I wait is until the WTS light goes off, but I usually start it before it goes off. Every other start up for the rest of the day I just turn it over immediately.

With a good running truck you shouldnt even need to use your glowplugs. Not down here. IMO

You are for sure from Alabama LOL
 

·
FNG
Joined
·
6,018 Posts
Yup once the light goes off crank it Blake.

Thats most of where your problem is from. The light isnt based on glowplugs alone.
 

·
Reppin' the 6.4L
Joined
·
2,341 Posts
Discussion Starter #73
No. You are just drawing more power doing that. What I do is: On the very first start up I let the glowplugs work for a little bit. The longest I wait is until the WTS light goes off, but I usually start it before it goes off. Every other start up for the rest of the day I just turn it over immediately.

With a good running truck you shouldnt even need to use your glowplugs. Not down here. IMO
Yup once the light goes off crank it Blake.

Thats most of where your problem is from. The light isnt based on glowplugs alone.
Okay, I didn't even know that! I guess I learn something new everyday. Thanks guys!!

I'm bout to purchase some Rev-X and see if my engine likes me any better. The T-5 helped out a little bit, but I left it sitting for almost two days (which almost never happens, usually driven about every 8 hours or less) and the engine temp was at 51*. It fired great, but man, the injectors were incredibly loud and it was ultra-sluggish. I think I might have the common case of stiction. Rev-X to the rescue!! I'll be hitting up Tim within the week to order two bottles.

You are for sure from Alabama LOL
Don't be a hater. LOL
 
61 - 74 of 74 Posts
Top