Ford Power Stroke Nation banner

1 - 7 of 7 Posts

·
Registered
Joined
·
83 Posts
Discussion Starter #1
SO I read up on here the other day about the LED mod. I thought it would be a nice thing to have, so I got all the stuff to do it. Wire, Red LED with resistor already in it (radio shack pt# 276-270) and an inline 1 amp fuse. No matter what terminal I connect it to on the glow plug relay, I cannot seem to get it to work. This is on an obs and the only terminal I could get different result was from the small far left terminal. From what I read on line, the wire to the led needs to be connected to the farthest terminal towards the back. This is the far big one and when I connected it to it, the light would stay constantly on. Then other big terminal along with the small one to the far right would not do anything. When connected to the far left small terminal, It would light up, and then turn off just like the Wait to Start light. But then the LED would stay on when the truck was running. I don't know what Im doing wrong unless the light is always supposed to be on while the truck is running. Nothing I found on line showed it staying on. I don't have a volt meter available to me to test the terminals. But I mean this is a strait forward thing. Literally one wire with a fuse in it to the led. Then just grounding the other wire...
Both my friend and I's majors are electrical engineering and we cannot figure it out to save our lives.
 

·
Registered
Joined
·
5,373 Posts
Run it from the big terminal with the wires that go to the glow plugs. Of course, tie the other terminal/lead of the LED to a ground in the cab.

Are you sure you have the polarity of the LED itself correct?
 

·
Administrator
Joined
·
8,630 Posts
if the LED does not come on when connected to the output of the glow plug relay with key in the run/on position, that means that either
1: your glow plug relay is bad.
or 2: your engine is hot enough to shut the glow plugs off.
 

·
Registered
Joined
·
3,387 Posts
3: you have the wrong polarity on LED
as Madpoque pointed out LED does care about + and - unlike a halogen bulb
 

·
Registered
Joined
·
83 Posts
Discussion Starter #5
Tuns out I had it right on the last terminal I left it on. Just we didn't know it would still be on for a little bit while the truck is running, then eventually stun off.
 

·
Administrator
Joined
·
8,630 Posts
yup, the light can stay on for up to 2 1/2 minutes after the wait to start light goes out
 
1 - 7 of 7 Posts
Top