Ford Power Stroke Nation banner

1 - 1 of 1 Posts

·
Registered
Joined
·
137 Posts
Discussion Starter #1
I will probably get crap for posting in more than one forum but I don't care.

I've been having an ISSPRO EV1 gage issue. My pyro started indicating consistently 300 degrees less than normal no matter what. I read the online trouble shooting pages, I searched multiple forums for various key words and still didn't find anything tangible to immediately go after. I emailed Dieselmanor last night. They emailed me first thing (that is awesome customer service) this morning and said they couldn't help me but to contact ISSPRO. Awesome on their part! immediate response. I wasn't sure how to take it. I called ISSPro this morning and the operator put me through to the tech department who listened but politely stated that there was someone more knowledgeable who would contact me back. I didn't hold my breath. Holy Crap! 3 hours later the expert called me back and was POLITE in listening to my plight. I am sold on ISSPRO customer service alone. These guys will get my money for gages again, I promise. I told them they were old gages and had been installed in multiple vehicles and they didn't care. The problem is probably a loose connection in the converter box, but I wanted to praise them so here it is. Both Dieselmanor.com and ISSPRO had immediate, friendly and patient customer service. It is sad that the polite and courteous response is the abnormal but I wanted to give them a shout out for their efforts. Thanks for reading my .02 cents.
 
1 - 1 of 1 Posts
Top