Ford Power Stroke Nation banner

1 - 20 of 30 Posts

·
Registered
Joined
·
1,524 Posts
Discussion Starter #1
I could be wrong but I would of thought my truck would doing better.

I dyno'd it and popped up 539 and 1089 on Dunbars Dyno and then went out to the track and the I couldnt get better then 8.31 with a 60' time of 1.78 and a top speed of 82 mph. All in the 1/8th

With the mods I have, could something be wrong or is it about right?
 

·
Registered
Joined
·
9,722 Posts
I wouldn't worry about the dyno numbers. The track time is a little high for 35's and your mods. Even with the 1.78 60 foot. With the same size tires I was running 8.1 with a 1.74 60 foot, and an 8.2 with a 1.80 60 foot.
 

·
Registered
Joined
·
1,524 Posts
Discussion Starter #5
I wonder if my wastegate needs to be adjusted. I dont know the easiest way to check/adjust it.
 

·
Registered
Joined
·
750 Posts
Watch your backpressure, it should be around 70psi. WOT. You may need to adjust the wastegate a little to get this reading.
 

·
WWDD
Joined
·
10,531 Posts
so stock pump, stock injectors, what tune are you running a standard 310 or a pump tune 310?
 

·
WWDD
Joined
·
10,531 Posts
Sounds to me like your truck isnt able to maintain rail pressure with the standard 310 (modded 310 has less PW) what is your rail pressure with each tune at WOT?
 

·
WWDD
Joined
·
10,531 Posts
rail pressure is pretty important, go make some WOT runs with everything warm and see what it is, It should maintain 24600, i think thats what honestly killed me on the dyno at the DPC was low rail pressure...
 

·
Registered
Joined
·
113 Posts
:ford::eek:I remember when his truck was more stock than mine. :bow::bow:





































Now I want to know the rest!! lol
 
1 - 20 of 30 Posts
Top