Ford Power Stroke Nation banner

1 - 8 of 8 Posts

·
Registered
Joined
·
140 Posts
Discussion Starter #1
Working on a guys truck and looking for some input....


95 F-Superduty w 7.3 Powerstroke 5spd, very poor maintenance history, oil pressure gauge on the dash shows just under the "N"

The guy just put a new oil pan in it and after he finished with the oil pan he tried to start it, no go, crank and crank and crank, no white smoke.

I look at it and I notice that the oil resivour is empty, fill it up, nothing...
Put a gauge on the HPO side and cranked, pressure never got over 50psi.

I took the IPR out and sure enough it was stuck open, i give it a shot of brake cleaner and air and everything started moving again, reinstalled and got the truck running. Every now and then the truck would stumble, so i sat there holding the fuel pedal so the truck was turning around 2,000 rpms then let off real quick, truck dies. I then tried to start it, got nothing. I gave the IPR a little love tap with a long 3/8" socket extension and the truck took off again.

I figured the IPR shaft was scored or something so I ordered a new Ford OEM IPR. Got that installed and everything was running good while i was there. Got a call today saying that the trucks doing the same thing again.

So long story short, what would cause a new ipr to stick open?

I've read somewhere that there is a valve that allows unfiltered oil to go to the HPOP while the motor is cranking, could that valve be stuck open, allowing unfiltered dirty oil to be going across the ipr and causing it to stick open.

Any input would be appreciated,
Thanks guys
 

·
Headwind Magnet
Joined
·
626 Posts
Two quick thoughts: Did you use any oil additives (not fuel) to "clean" the motor after its poor maintenance history? Doing so can cause repeated IPR failures. Have you hooked the truck up to a scanner to check the ICP? Maybe the IPR isn't the bad part...
Best,
Jim
 

·
Registered
Joined
·
140 Posts
Discussion Starter #3
Two quick thoughts: Did you use any oil additives (not fuel) to "clean" the motor after its poor maintenance history? Doing so can cause repeated IPR failures. Have you hooked the truck up to a scanner to check the ICP? Maybe the IPR isn't the bad part...
Best,
Jim
The guy did put some of that engine cleaner crap in the oil, i just cringed when he told me that. I understand that oil quality is critical for these HEUI's. Could that ruin an IPR in not even and hour of operation?

Tapping on the IPR resolves the issue, cant imagine how it could be anything else then...
 

·
OEM Moderator
Joined
·
9,381 Posts
Two quick thoughts: Did you use any oil additives (not fuel) to "clean" the motor after its poor maintenance history? Doing so can cause repeated IPR failures. Have you hooked the truck up to a scanner to check the ICP? Maybe the IPR isn't the bad part...
Best,
Jim
I remember this as well but the particular brand name escapes me. Time for an oil change perhaps?
 

·
Headwind Magnet
Joined
·
626 Posts
The guy did put some of that engine cleaner crap in the oil, i just cringed when he told me that. I understand that oil quality is critical for these HEUI's. Could that ruin an IPR in not even and hour of operation?

Tapping on the IPR resolves the issue, cant imagine how it could be anything else then...
Engine cleaners play havoc with these motors. I think what you need to do is an oil change and clean the IPR per these instructions: New Page 0.

Hopefully that will take care of the problem and you won't need a new IPR.
Best,
Jim
 

·
Registered
Joined
·
328 Posts
Uuuuummmmm the link no work. And i think i have the same problem and would like to see how to do it. Could someone please fix the link thanks guys
 

·
NEWBIE to PSN
Joined
·
29 Posts
When you are tapping on the IPR are you actually tapping on the coil. Maybe the coil is the problem. Try swapping it with a known good one before you pull the IPR again. It doesn't happen often but the coils can go bad. Worth a try.
 

·
All done now
Joined
·
22,486 Posts
Uuuuummmmm the link no work. And i think i have the same problem and would like to see how to do it. Could someone please fix the link thanks guys
Link works perfedct for me. But here is another link. Same thread, but a different link,

New Page 0
 
1 - 8 of 8 Posts
Top