Ford Power Stroke Nation banner

1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hey guys, new to the site and really need some input. I have an 02 7.3 PSD. For about 6 months now I've been have intermittent power loss that mainly happens when climbing hills or accelerating. It cruises fine on flat roads usually but when the power cuts out it falls on its face. It idles fine. I've replaced 3 injectors, VC gaskets, UVCH, IDM, IPR, ICP, CPS, and blue spring upgrade(All Motorcraft/international parts from Riffraff) Also 50 cent mod. I did a EBPV delete, installed bellowed up pipes, new exhaust, and a PHP Hydra chip. Scanning it with my AE isn't giving me any concerning codes and no CEL. Buzz test and C.C test both passed. Im stumped now and tired of throwing money at it. I havent checked fuel pressure or checked the in tank screens. I think that's my next step. Any input is appreciated!
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
I would check the fuel tank screens like you mentioned. Monitor fuel pressure under a load.
Ok thanks will do, the fuel pressure tester I rented from the auto parts store didnt have the right fightings to hook up to the truck. Is there some kind of adapter for these trucks?
 

·
Registered
Joined
·
4,834 Posts
If you have a stock fuel system you have to tap into one of the square plugs on the heads. IIRC passenger side front is the easiest.
 

·
Registered
Joined
·
293 Posts
You will need to check FP under load, idle will tell you nothing. It's pretty easy to put a permanent FP gauge in the cab hooked into the fuel bowl with an adapter sold by many suppliers. Unfortunately a lot of guys have spent necessary time and money throwing parts at it before verifying FP under load. A nice Isspro EV2 FP gauge will set you back a couple hundred but will be something you can always use to troubleshoot the fuel system in seconds instead of wasting a lot of time and money on guesses.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
I checked the fuel pressure under load and it didnt go below 65psi. I ran the AE on live monitoring for IPR duty cycle and ICP pressure and everything looked good. Im stumped! It runs good on straight aways/level road but when i hit an incline it falls flat on its face. When it loses power it still sounds like its running fine, the RPMs just jump up and it has no power.
 

·
Registered
Joined
·
68 Posts
I don't know if I'm following you correctly but my truck would have a intermittent power loss it mostly would happen under hard acceleration. I swapped CPS ICP and finally found that the throttle pedal had a dead spot in it. It would act like you're foot slipped off the pedal, the truck would idle fine I would double pump the pedal and away I would go. Hope this helps
 

·
Registered
Joined
·
6 Posts
Discussion Starter #10
I don't know if I'm following you correctly but my truck would have a intermittent power loss it mostly would happen under hard acceleration. I swapped CPS ICP and finally found that the throttle pedal had a dead spot in it. It would act like you're foot slipped off the pedal, the truck would idle fine I would double pump the pedal and away I would go. Hope this helps
Thanks! i will mess around with that and see what happens. Was it your Accelerator Position Sensor? And when the power cuts out, you can floor it and the RPMs will go up to 2500 or so but theres just no power. Sometimes ive noticed if i let off the gas pedal and let the rpms drop and get back on it, it will be better.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #11
Could the power problem be my torque converter slipping? I watched the torque converter slip on the Auto Enginuity the other day and the slipping seemed to be worse during the times the truck lost power
 
1 - 11 of 11 Posts
Top