Ford Power Stroke Nation banner

1 - 14 of 14 Posts

·
Stroken it 7.3,6.0,6.4
Joined
·
1,239 Posts
Discussion Starter #1
Well As the title says I installed the Retro solutions 6000K HID kit in the 01 Excursion and they are bright as hell which is awesome. It is a very well put together kit also but I have two problems with it. One is when the truck is running and some times not always but if I turn the lights on or off it will kill the truck or make it cut out for a second. Not to sure how lights could do that but they are. And my second question is I have no high beams. I went looking a little but could not find any answers and when i do pull the High beams on the blue light on the dash does not come on.
Any help would be great guy
Thanks
Nick
 

·
Stroken it 7.3,6.0,6.4
Joined
·
1,239 Posts
Discussion Starter #3
Switch the hook ups to the other battery and try it. Mark had a similar issue.
The one on the Drivers side or Passenger side? Its on driver side now.
 

·
Registered
Joined
·
654 Posts
if you have to ground the lights do not ground threw the battery. I had this problem with my kit and would kill the truck when i would turn the lights on and i grounded to the battery than i removed that and regrounded to the truck. Worked great after that
 

·
Registered
Joined
·
597 Posts
If retro solutions are so great how come everyone always has a problem with their truck after installing them.
 

·
Registered
Joined
·
36 Posts
Hey just a tidbit of info: HID light bulbs do not have a second filament/burner in the bulb, therefor no high beams. I have a kit for my bronco that has an actuator that pulls the light bulb asy back and forth to simulate high/low beams. and HID kits are finnicky if not wired correctly.
 

·
Registered
Joined
·
27 Posts
DP had problems with the older cables. That's gotta be 3 years old already though.[/QUOTE]

I have an old Cable from back in 08 and talked with DP-Tuner yesterday about my HID light issue. Installed them a week ago and when i turn the lights on the switch restarts itself. They told me to get a new cable(because it also interferes with my radio signal) and add a ground to the lights. So this is what i will be trying. Love the lights to much to take them back off.
 

·
Stroken it 7.3,6.0,6.4
Joined
·
1,239 Posts
Discussion Starter #11
Well tried switching the cables and still no luck it will still turn it's self off. So if I got my tuner pre 08 then it could be my Dp tuner cable? Other than this the lights work awesome!
 

·
Registered
Joined
·
150 Posts
I'm looking at getting HID's in January. What did you guys end up doing to resolve your HID and DP issue?
 

·
Registered
Joined
·
93 Posts
1 - 14 of 14 Posts
Top