Ford Power Stroke Nation banner

1 - 15 of 15 Posts

·
Registered
Joined
·
381 Posts
Discussion Starter #1
i have a 01 7.3 thats been in and out of 4 different shops and they can't fix the problem. the truck surges and had a pulsing vibration feeling at idle and a shake around 40-50 in the wheel. if i take the icp off its fine.. iv replaced the icp and harness and no fix. also an injector and still no fix.. anyone know of anyone or a place around indy area that knows 7.3s well? thanks
 

·
NYFB. Thats what.
Joined
·
384 Posts
I could help..
 

·
Registered
Joined
·
152 Posts
sounds like the ipr wiring could be messed up, also check ipr% at idle should be 11-14% if lower than that it may be mechanically stuck or sludged up
 

·
Registered
Joined
·
1,241 Posts
Thanks Trevor for mentioning us. We are not a sponsor on here so I will not try to contact anyone but I wanted to clear up that we are not the "stacks" company and never used to work on import cars. Your problem does seem to be in the high pressure oil system and we would gladly help you get your problem resolved if you have not yet done so.
 

·
Registered
Joined
·
116 Posts
Ray @ S&R Diesel Concepts 317-441-5359
He is a super good dude ... real honest and great prices.. TELL HIM Tyler Sent ya
he just did a huge project on my step dads 2008 f450
 

·
Registered
Joined
·
42 Posts
Where in Indiana are you located?
 

·
Registered
Joined
·
381 Posts
Discussion Starter #11
hey guys.. i picked up an ae.. got the idle problem figured out but the shaking is still there. just been real busy with work.. i don't know how to really read the AE yet.. I'm thinking the shaking could be torque converter/ tranny or the motor.. it shifts good and smooth but i notice it after i shift into 3 rd the most. feel it in the wheel and pedal.. does anyone know how to read the ae very well? everyone iv taken it to has no clue since it isn't throwing any codes. my pick up screen on the sending unit was broke off in the take and i repaired that. i don't know if that could have caused any problems but don't think so.. can i check my hpop with the scanner? thanks guys
 

·
Registered
Joined
·
381 Posts
Discussion Starter #13
little back story. when i got the truck the gauge said 1/4 tank and i was really out of fuel. didn't think anything of it just maybe bad wiring on the unit in the tank. i was getting a lot of rust and dirt in my fuel bowl and it even plussed up the injectors and i lost power. i ran cleaner and kept the tank up and it ran ok had the shudder still but the power was there. i replaced the icp and checked the codes nothing.. then i bought a new set of reman injectors and had a shop install them. truck ran good for about 750 miles then started to shudder again. i then after that got into the fuel and noticed the pick up screen was off the sending unit and it was broke off and picking up everything in the tank. the fuel bowl wasn't to bad but did have some gritty stuff starting to build up in the bottom of the tank.. so i wonder.. could just that amount of miles with the sending unit broke off screw up my new injectors?.. I'm gonna check the fuel pressure friday hopefully .. I'm kinda at a loss don't wanna keep throwing money at it just wanna know what it is!
 

·
Registered
Joined
·
258 Posts
first thing i would do is stop driving it. drop the tank and drain and get it cleaned and clean every line you can. Change your filter. make sure you clean the fuel bowl also.
 

·
Registered
Joined
·
381 Posts
Discussion Starter #15
just did all of that the other night. everything is clean now. there was some junk in the tank but all clean and still have the problem
 
1 - 15 of 15 Posts
Top