Ford Power Stroke Nation banner

1 - 16 of 16 Posts

·
Registered
Joined
·
92 Posts
Discussion Starter #1
ok, put the scanner on the truck and was monitoring the icp pressure, i have suspected my icp was bad for a while but could never confirm. at idle it was jumping between 500-530 and i rev to 2k real quick and it would reach about 1100. i had one of those awesome resistors in the sensor :lame:. while the truck was running i pulled the icp plug (bad idea?) and the truck ran different, it stayed a steady 725 pressure at idle and traveled up smooth when i revved it. but then something crazy happened and the truck started loping. it was loping like it had a huge cam and would barely run so i looked at the scanner real quick and it was over 3000! :confused: idk what happened. so i shut it down, plugged the sensor back in and it still holds that steady 725 (default??) and now no change when plugged in or unplugged, but with the sensor plugged in twice on the way home it did its loping stuff and shut down, the second time i did it i had to unplug the sensor to get it to idle or move. i guess that was finally the death of my icp or was this something else? (btw the truck is an absolute dog now, i guess with the default parameters? its really slow.)
 

·
Registered
Joined
·
110 Posts
Disconnect both batteries, replace ICP, clean IPR and reinstall, reconnect batteries and start truck. Not a guarantee but this is what I would do first. Santex Truck Center(International Dealer located in San Antonio) can fix you up and get your sensor shipped in the morning. Good luck. Write down the codes that you pulled then reset with scanner.
 

·
Do you smell something?
Joined
·
641 Posts
DON"T waste your time cleaning the IPR, I can't believe how many times that gets thrown around here....

Does the ICP sensor have oil in the plug(insert yes here) it is biased and you need a new one...

NEXT look at the wiring to the IPR sensor itself, is it melted, or shorted... if yes replace....;

Problem will be solved...

The truck is supposed to defualt to 725 at idl, and I can't remember the pressure at the high side default....

BUT REMEMBER your scanner couldn't be reading 3000psi ACTUALLY you had the sensor unplugged :) there is no where else for the Scanner to get a pressure reading from, but the INJECTION CONTROL PRESSURE SENSOR :)

It was reading the default values the pcm was giving.... without a manual guage on the truck while disconnected you will have no idea what is in the heads....


Swap your sensor and have a good time again :)
 

·
Registered
Joined
·
92 Posts
Discussion Starter #4
thanks for the info guys, just out of curiosity i know someone with an icp for an OBS is this the same?
 

·
Registered
Joined
·
110 Posts
Ask him to give you the part number off the sensor and compare it compatable sensors to your truck.
 

·
Registered
Joined
·
92 Posts
Discussion Starter #8
hmm on ebay they are 70 bucks, says it replaces part number F6TZ9F838A so im guessing it needs to have that part number.
 

·
Registered
Joined
·
92 Posts
Discussion Starter #10
yeah they are 90 if you use the buy it now function but the bid is at 70 and there is more than one.
 

·
Registered
Joined
·
110 Posts
Ford/International parts interchange on here. Also Call Ford and ask guy at part counter what original part number was then what is the new part number. These things have been changed around from year to year but I assume they will all work together, some better, some longer, etc. Then compare with your buddy.
 

·
Registered
Joined
·
110 Posts
Sorry dude, I was thinking CPS, you can still do the parts interchange
 

·
Registered
Joined
·
92 Posts
Discussion Starter #13
just for clarification, these trucks are supposed to be very slow with that the icp unplugged right? like extremely slow?
 

·
Registered
Joined
·
92 Posts
Discussion Starter #15
well thats great news, im going to pick it up either today or tomorrow, i couldnt stand how slow my truck was with that sensor unplugged so i plugged it back in and it hasnt stalled since i did it (15 miles).
 

·
Registered
Joined
·
49 Posts
this is only some what related but are all IPR's the same? i hav e 97 pump and IRP sitting on the shelf and am thinking my early99 IPR is going bad are they the same?
 
1 - 16 of 16 Posts
Top