Ford Power Stroke Nation banner

1 - 18 of 18 Posts

·
Registered
Joined
·
231 Posts
Discussion Starter #1
So my icp sensor has went out for the third time in about 8 months I just ordered a new harness for it to see if that could be the problem but is anyone else had this problem
 

·
Banned
Joined
·
2,444 Posts
I had two bad ones in a month once.
Did you order just the pigtail or the whole engine harness?
 

·
Registered
Joined
·
231 Posts
Discussion Starter #3
Pretty sure the harness all three wires and the part that plugs in
 

·
Banned
Joined
·
2,444 Posts
How about some hardened line and put the sensor on the end of that.

sent from my Smart Car
 

·
Registered
Joined
·
166 Posts
My question is were the heck is the sensor on my 2004? Heck I don't even know what it looks like.... but have been told mines bad.. I want to get it replaced...
 

·
Registered
Joined
·
231 Posts
Discussion Starter #8
Should be on the pass side of the engine about the valve covers I believe
 

·
Banned
Joined
·
2,444 Posts
:whs:
Its about 2 inches from the front of the passenger side valve cover. Almost below the alternator.
 

·
Registered
Joined
·
166 Posts
Lol thanks guys.. I'll have to look in the morning....
 

·
Registered
Joined
·
166 Posts
What is the voltage suppose to be at the icp sensor?
 

·
Banned
Joined
·
2,444 Posts
Depends what the injection pressure is...

sent from my Smart Car
 

·
Registered
Joined
·
166 Posts
so what causes the icp sensor to go bad?
 
1 - 18 of 18 Posts
Top