Ford Power Stroke Nation banner

1 - 4 of 4 Posts

·
nj
Joined
·
5 Posts
Discussion Starter #1
Hello I have a 2005 6.0. Bone Stock! The check engine light came on the other day. I hooked up the scanner and got two codes P0113 and P1102.
P0113 - IAT - Intake Air Temp Sensor
P1102- MAF sensor issue

I have been trying to find more info on the IAT sensor. I have already replaced the gummed up IAT sensor in the intake manifold and it did not clear the code.

After doing some more searching I realized that there are two IAT sensors.

I believe the other one (IAT1) is located in the MAF sensor.
any info on testing or cleaning this sensor to try and clear the code would be much appreciated before I replace the $$$ MAF sesnsor.

I already tried cleaning it with some solvent and all connections on the plug are secure. after clearing the code the MAF sensor code still pops up

thanks Kyle
 

·
Registered
Joined
·
3,600 Posts
The first IAT and MAF are together inside the MAF sensor. Did you already try to clean it? You want to make sure the truck has been off because the MAF gets very hot, and hitting a hot wire with solvent is no good! You may want to try and clean it with MAF sensor cleaner. Does all the wiring look good?
 

·
nj
Joined
·
5 Posts
Discussion Starter #3
thanks for the reply All the wiring looks fine. I have never seen MAF cleaner. I will have to search around and give that a try. Thanks for your help.
 

·
Registered
Joined
·
3,600 Posts
I found some special MAF cleaner at my local auto parts store, it was the same brand that makes brakeclean, but it's in a grey can I think...
 
1 - 4 of 4 Posts
Top