Ford Power Stroke Nation banner

1 - 10 of 10 Posts

·
Registered
Joined
·
7,358 Posts
Discussion Starter · #1 ·
I've been holding on to a 38r for a while now. My white truck (single cab) Is in need of replacement pedistal o-rings...So I assume its only right to throw on the 38r, right?LOL

Long story short I geuss its finally time to start modding it. 265k miles of bone stock is way too long. Getting turbo and chip today. should make for a fun little truck. Also accepting donations for injectors :D

Just in case anyone is wondering, its a single cab long bed 2wd. Big plans for it in the future, in the far future that is.
 

·
All done now
Joined
·
22,483 Posts
I've been holding on to a 38r for a while now. My white truck (single cab) Is in need of replacement pedistal o-rings...So I assume its only right to throw on the 38r, right?LOL

Long story short I geuss its finally time to start modding it. 265k miles of bone stock is way too long. Getting turbo and chip today. should make for a fun little truck. Also accepting donations for injectors :D

Just in case anyone is wondering, its a single cab long bed 2wd. Big plans for it in the future, in the far future that is.
You still have a bunch of glow plugs? I would be interested in buying a set from you to help start your injector fund. If the price is right. I will give you more than you paid for them. :poke:
 

·
FORD..THE ROCK CRUSHER
Joined
·
2,350 Posts
You still have a bunch of glow plugs? I would be interested in buying a set from you to help start your injector fund. If the price is right. I will give you more than you paid for them. :poke:
did some one get in the glow plug's for a penny deal ???
 

·
Registered
Joined
·
7,358 Posts
Discussion Starter · #5 ·
did some one get in the glow plug's for a penny deal ???
Sure did! at one point I had close to 4 sets.

Andy, I will see what I can dig up. I have no idea where I stuck them all at.

Just an update, tried putting the chip in, and nothing. So now I have to figure out whats up with that.
 

·
FORD..THE ROCK CRUSHER
Joined
·
2,350 Posts
i got wind of that the first day it happend and started a thread on it over on FTE,,,a bunch of us made out on that deal lol...
 

·
Back in Black
Joined
·
1,379 Posts
i have injectors forsale : )
 

·
Death Row Inmate #7
Joined
·
1,458 Posts
Sure did! at one point I had close to 4 sets.

Andy, I will see what I can dig up. I have no idea where I stuck them all at.

Just an update, tried putting the chip in, and nothing. So now I have to figure out whats up with that.
you did clean the part that the chip connects to right??? :poke:
 

·
Registered
Joined
·
7,358 Posts
Discussion Starter · #9 ·
you did clean the part that the chip connects to right??? :poke:
Of course. This truck has had a few different chips in it. The chip was actually working for about 5 minutes, then the truck killed. While the chip is in the truck wont start. If I take it out, it cranks right up
 

·
All done now
Joined
·
22,483 Posts
If it has been a while since it has had a chip in it, you might want to jerk the PCM out and hit the connector pins a couple times with a scotchbrite pad. Might have a little corrosion on them. You know from that dry climate y'all have.
 
1 - 10 of 10 Posts
Top